WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Shadowbox JS does not play YouTube video (13 posts)

  1. SiftingPoint
    Member
    Posted 1 year ago #

    Shadow Box JS does not play the YouTube video when linked on my blog page. The window pops up but remains black.

    Shadow Box works great on my video page that I use YouTube gallery on.

    Is there a settings change that I can make?

    Thanks.

    Geoff

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. joveeno
    Member
    Posted 1 year ago #

  3. SiftingPoint
    Member
    Posted 1 year ago #

    That is cool but it causes the video to open full-screen in a new window and does not open in ShadowBox in a pop-up window on the same page.

    Do you have any other ideas? Are you familiar with Shadowbox?

    Thanks for your help.

    Geoff

  4. johnflufin
    Member
    Posted 1 year ago #

    YouTube links must be formatted like so http://www.youtube.com/v/youtubeidgoeshere

  5. vind
    Member
    Posted 1 year ago #

    I've tried the following YouTube link formats, but keep getting the same result too:

    http://youtu.be/video_id
    http://youtube.com/v/video_id
    http://youtube.com/embed/video_id

    Neither one works; the shadow box is seen loading for a split second, before it redirects me to a new page and opens the video in full-screen.

    The videos are loaded from images that link directly to the videos, by the way, as in a video gallery of thumbnails; although, I don't think this would pose any problem?

  6. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    @vind

    please start your own topic.

    this makes it easier to track the problems.

  7. NYSBADMIN
    Member
    Posted 1 year ago #

    I'm having the same issue. YouTube links in any of the variations are not opening in a Shadowbox. Images work great though.

  8. elba00
    Member
    Posted 1 year ago #

    Confirmed, YouTube links in any variations only dim the page, but do not load videos, pictures and galleries work fine.

  9. Han
    Member
    Posted 1 year ago #

    Calling the shadowbox manually + using the embed YouTube link as follows works for now:

    <a href="http://www.youtube.com/embed/ID_GOES_HERE?autoplay=1" rel="shadowbox;width=640;height=385">Watch the video</a>

    But then again, you have to manually add width and height.

  10. rigel09
    Member
    Posted 7 months ago #

    This worked for me:

    <a title="" href="https://www.youtube.com/watch?v=VIDEOIDHERE&width=640&height=480">Click to watch</a>

  11. Droopie
    Member
    Posted 6 months ago #

    Thanks Han - that trick worked for me also. But now I am having an issue with the youtube videos playing the showing the related videos at the end. I have already inputed the '?rel=0' coding, but no dice.

    Example of work is http://puasummit.com/about#speakers

    Thanks in advance.

  12. Han
    Member
    Posted 6 months ago #

    Droopie--make sure your URL query strings starts with a ? and separated by &. Here is an example of one of your video's code:

    This:
    http://www.youtube.com/embed/RyfmqoHdT7M?rel=0?autoplay=1

    Should be:
    http://www.youtube.com/embed/RyfmqoHdT7M?rel=0&autoplay=1

  13. Droopie
    Member
    Posted 6 months ago #

    YUP! that was it, I forgot the separator. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic