WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Shadow box not working (6 posts)

  1. dianacarpenter
    Member
    Posted 2 years ago #

    I'm not sure what i'm doing wrong here but i've installed and activated the plugin and the shadowbox effect is still not working on my site.
    http://fiercesalon.info/?page_id=17

  2. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin attempts to cache a JS file in the uploads directory. At first glance it seems you have moved the uploads directory from being /wp-content/uploads to /images

    The following is the URL in which shadowbox is expecting the JS file to be at:

    http://fiercesalon.info/images/shadowbox-js/560b677eadfdbeb86b976683f8ef4d70.js?ver=3.0.3

    When you try to pull up that URL you get a 404 error. Check to see if that file actually exists. If it does then make sure to modify the file system level permissions to allow the web server to read the file.

  3. dianacarpenter
    Member
    Posted 2 years ago #

    1. thank you sooooooo much for the quick response, the site is going live this weekend and i've ran into road blocks every freaking step of the way. you rock.
    2. i'm unable to locate the file, do you think it'll be easier if i was to move the files back to the wp-content/uploads directory?
    3. you rock again for responding so quick!

  4. Matt Martz
    Member
    Plugin Author

    Posted 2 years ago #

    The first step would be to go to Settings->Shadowbox JS and just click the "Save Changes" button. This should attempt to cache the file.

  5. dianacarpenter
    Member
    Posted 2 years ago #

    Oh happy day!
    I just uninstalled the plugin, deleted my media images (luckily there was only 9 or so images), in media settings put down the full url path to put images in http://fiercesalon.info/wp-content/uploads (unchecking the year/month organization), reinstalled the plugin, reuploaded my pictures, and it worked! for some reason last night I was pulling my hair out over this, oh happy day!

  6. SFCohen
    Member
    Posted 2 years ago #

    Hi, Matt -- I have something of the opposite situation: Shadowbox is working and I don't want to break it while I'm trying to fix a different problem.

    Random photos have been disappearing from my media library, and then they don't show up on my site (www.visiblelightphoto.net). In order to fix this, I installed the WP Flash Uploader plug-in (http://www.tinywebgallery.com/blog/wfu) which also includes a Sync Media Library module that's supposed to take care of the problem.

    When I go to the Sync Media Library plug-in, it shows me all the files that are in the uploads folder that aren't in the media library. This includes all the files in the Shadowbox JS folder that's sitting inside the uploads folder.

    So - I gather from the above posts that I need to keep the Shadowbox files in the uploads folder in order for the plug-in to work. If I sync and pull all those Shadowbox files into my media library, is that a problem?

    Thanks!
    [=sfc=]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic