WordPress.org

Ready to get started?Download WordPress

Forums

Social Gallery Lite
[resolved] SG misbehaves when photo not linked to media file (2 posts)

  1. OC2PS
    Member
    Posted 1 year ago #

    Fantastic plugin. The developer isn't kidding when he says in description that this one kicks ass.

    My one last remaining peeve after release of 2.1.1 (which fixed my other peeve) is:
    if a photo is not linked to the media file (and linked to, say attachment page, another page or an external page) then clicking on it pops up Social Gallery which presumably attempts to find the linked media file and failing to that, closes in a couple of seconds....
    Ideally, Social Gallery should recognize that the image is not linked to media file and gracefully fall back to the link URL.

    http://wordpress.org/extend/plugins/social-gallery-lite/

  2. mikemayhem3030
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    It takes that first click to know that it's linked to a photo currently.

    What you can do though, is find the class of the images you don't want to open, and add it as a disclude CSS (this may only be in the PRO version though)

    So the other thing is for the images you DO want to open, put that into the CSS selector so something like

    <div class = "myGallery">
    //photos in here
    </div>

    And you put

    .myGallery a:has(img)

    into the settings for CSS (don't forget the . )

    Then any other images (like featured images that link to a post) behave normally

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.