WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
[resolved] sfc_like plug-in fix (5 posts)

  1. lance_kidd
    Member
    Posted 1 year ago #

    Hey,

    I don't know if this would help anyone, and I haven't tested it much, but it seems to be working. I had already removed the like buttons from the plug-in from showing up on all my site's pages, because the plug-in does not have an option to exclude pages or categories.

    I put this in my child theme's function file to remove some of my theme's filters and other stuff. Let me know if this isn't a great way, because I'm not a PHP expert (or even good enough to be called a novice), but it seems to be ok.

    <?php //Remove annoying theme styles
    function my_remove_filter(){
       //Simple FB Connect
       if (is_page() ) :
    	remove_filter('the_content', 'sfc_like_button_automatic', 30);
       endif;
    }
    add_action( 'init', 'my_remove_filter' );
    ?>

    http://wordpress.org/extend/plugins/si-contact-form/

  2. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    The problem is caused by my plugin. It is something I can try to fix.
    The form POST action in my plugin being processed at the same time the page content prints from the shortcode. I designed that part wrong.

    Shortcode is not supposed to handle form processing logic. The form needs to process earlier on during WP init, separate from the time the page content prints from the shortcode.

    This plugin has so many features it will take me quite some time to rearrange all the code properly. I started working on it, but do not know for sure when it will be fixed.

  3. lance_kidd
    Member
    Posted 1 year ago #

    I use the simple facebook plug-in and yours, but using the code above, I was able to remove the sfc plug-in from executing on all my pages because that plug-in doesn't give the option to do that in settings.

    I thought if some people were having a conflict it may help.

    Thanks for a great plug-in though. I've used it for about three years.

  4. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for sharing your solution. I think I have the correct solution now by fixing my plugin. This would make your workaround not needed.

    Would you be able to help me test the new version to see if it fixes the problem? If yes, please remove your workaround before testing so you get accurate results.
    See here:
    http://wordpress.org/support/topic/about-fast-secure-contact-form-redirect-problem?replies=24#post-3726681

  5. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    FSCF plugin version 3.1.7.2 resolved the problem

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic