WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] SexyBookmarks sends insecure sprite.png on HTTPS page using WordPress HTTPS (9 posts)

  1. microberto
    Member
    Posted 3 years ago #

    Hi, I have SexyBookmarks 4.0.5.6, WordPress 3.2.1, and WordPress HTTPS 1.9.1 on this site:

    Ron Paul T-Shirt

    If you add this item to the cart, and then proceed to checkout, you will get an insecure error from IE. Using Google Chrome Developer Tools, I'm getting this error:

    The page at https://www.libertybracelet.com/store/checkout displayed insecure content from http://www.libertybracelet.com/wp-content/uploads/shareaholic/spritegen/sprite.png.

    What's funny is that on this page, I have a custom field titled HideSexyBookmarks and it is set to 1, and that is working! So why is this sprite.png even trying to load???

    So I need a solution to either (or both) of these issues:

    1. Stop loading sprite.png when I disable SexyBookmarks on a page.
    2. Send over HTTPS on an HTTPS page.

    I am even telling WordPress HTTPS to FORCE everything to HTTPS, and it doesn't work with this. I assume the filter is getting underneath it or something.

    This site has no cache plugin on.

    Thanks!
    Mike

  2. microberto
    Member
    Posted 2 years ago #

    No updates on this? I don't think I'm the only one with this issue.

  3. Online Backup
    Member
    Posted 2 years ago #

    I'm experiencing this same issue.
    Any help will be greatly appreciated.

  4. Online Backup
    Member
    Posted 2 years ago #

    I added before line 792 of include/public.php:

    if ( is_ssl() ) $spritegen_basepath = preg_replace( '#^http://#', 'https://', $spritegen_basepath );

    And this fixed the issue. Hope this helps others.

    I'd appreciate it though if the developers could acknowledge this though and hopefully put something like this in the next update, because next time we upgrade this change will disappear lol

    Thanks.

  5. f1ngers
    Member
    Posted 2 years ago #

    Thanks for sharing Jason. I've been trying to fins a solution to the same problem for ages.

    Would you mind pasting the existing code before and after where you inserted the new code? I tried your code but it didn't work, so I'm thinking I pasted it incorrectly.

    Also, are you using the beta version?

    Cheers.

  6. freerobby
    Member
    Posted 2 years ago #

    Hi all,

    The reason WordPress HTTPS does not fix this is because we load some assets via javascript, which gets generated well before the WordPress HTTPS filters go into effect.

    We have a fix coming for this very soon; it will work both with and without the WordPress HTTPS plugin.

    Cheers,
    Robby
    Tech Lead, Shareaholic

  7. microberto
    Member
    Posted 2 years ago #

    Hey, looks like you guys fixed it! Thanks!

  8. Shareaholic
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all,

    The latest version of SexyBookmarks now fully supports SSL. Please update!

    Jay

  9. f1ngers
    Member
    Posted 2 years ago #

    When I uninstall and reinstall sexybookmarks it remembers my settings and for some reason I can't get it to work again.

    Can someone please detail a manual way of removing everything so I can do a fresh install?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic