WordPress.org

Ready to get started?Download WordPress

Forums

SKT Skill Bar
[resolved] Several "gage" on same page (6 posts)

  1. ninjamads
    Member
    Posted 5 months ago #

    Hi I'm having problems with having more than one
    [skillwrapper][/skillwrapper]

    Example:

    <h4>First</h4>[skillwrapper type="gage"]...[/skillwrapper]
    <h4>Second</h4>[skillwrapper type="gage"]...[/skillwrapper]
    <h4>Third</h4>[skillwrapper type="gage"]...[/skillwrapper]

    Example end.

    When i try to make this, it is only the first who displays the gage content.

    Is this not possible?

    Kind Regards Mads

    https://wordpress.org/plugins/skt-skill-bar/

  2. SKTThemes
    Member
    Plugin Author

    Posted 5 months ago #

    Mads,

    Please share with us your site and that page where you placed the code with the skt skill bar as activated.

    We can check and let you know why its not working or whether some other plugin is conflicting.

  3. mithun
    Member
    Posted 5 months ago #

    Hi SKTThemes,

    I'm facing the same issue as well. I'm developing the site locally, so there's a challenge in sharing a public URL that could help you. So, I'll have to be elaborate in this note.

    The issue is as follows:
    When I use one gage with several elements in it, the graphic appears. However, when I use multiple gages on the same post/page, only the first one shows.

    I looked at the HTML output produced and found that class="gc_active" is added only to the first gage (Which shows) and not for the other gages on the same page. I think this issue comes from the $wrapCode element that contains adding the gc_active class.

    My Javascript skills aren't excellent, but I guess the issue is from: jQuery(document).ready( function(). The scroll event is fired only once and doesn't for other gages.

    Could you help here, please? How could I make all id="gage_chart" active?

    Thanks in advance!

    Best Regards,
    Mithun

  4. mithun
    Member
    Posted 5 months ago #

    Hi SKTThemes,

    I tried adding the active class manually, but it doesn't seem to work. The issue seems to be one of Javascript. Only the first gage is processed. It appears that, as you're using ids to process the gages, only single instances are supported. I have tried deactivating all the plugins as well as with the default 2014 theme. I think the gage module needs to be reprogrammed. Please confirm if this is correct or whether I'm missing something.

    Thanks,
    Mithun

  5. SKTThemes
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Mithun,

    We will try to add many gages in different wordpress sites and then check if its possible to load them together.

    Please give us time till Monday to come back to you with an answer and solution.

  6. muellsammler
    Member
    Posted 1 month ago #

    Hello,

    i have the feeling that several gages on one page are still not working - is there a solution for this issue? If yes, could you please point it out here?

    Kind regards,
    bernd

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.