WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
Setup wasn't able to create the required database tables (9 posts)

  1. MI C
    Blocked
    Posted 1 year ago #

    Setup wasn't able to create the required database tables, on activate

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    New install or upgrade?

    Usually deactivating the plugin (if it's active) and activating it again from the plugin list solves this issue.

  3. MI C
    Blocked
    Posted 1 year ago #

    Like I said Setup wasn't able to create the required database tables, on clicking activate. its not activated at all. And yes it's a new install.

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Can't reproduce, and no other such reports at the moment, sorry.

    I could perhaps tell you how to manually set up the db tables, given some information about your site (multisite or single install, and your WordPress database prefix). This should certainly not be necessary though so it seems your permissions are set up strangely.

  5. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Another word on this: If you want me to take a look at your install, contact me via the email address in the GPL statement in the gviewer.php file. If you can give me temporary admin access I may be able to determine the problem you're having.

  6. jessica@whitefieldtax.com
    Member
    Posted 1 year ago #

    Hi

    First, great (till today!) plugin

    Secondly, started throwing up errors today.

    Tried deactivating and reactivating, I get "Setup wasn't able to create the required database tables" on reactivation.

    Deleted and reinstalled - still getting same error. Checked via FTP,plugin folder has been deleted, but are databases stored elsewhere?

    Any thoughts would be appreciated.

  7. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Jessica,

    You don't need to delete and reinstall. All you need to do is manually deactivate and reactivate from the plugin list.

    If that doesn't work, there may be a broader issue with the way your wordpress install is creating database tables. The plugin uses the standard WP database and wpdb object and isn't doing anything outside the ordinary, though some do have issues creating the tables on initial install for reasons I haven't determined yet.

  8. jessica@whitefieldtax.com
    Member
    Posted 1 year ago #

    Thanks, but the delete and reinstall was a next logical step.

    Alas still a problem with plugin, even after clearing caches and upgrading to lastest maintenance release of wordpress.

    I really don't want to get into the realms of database tinkering, so deactivated and found a substitute instead.

    Thanks for taking the time to reply.

  9. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    If you are interested in helping me solve the problem in your environment, feel free to contact me directly using the email address in the GPL statement near the top of gviewer.php. It's very hard to fix a problem I can't reproduce, unfortunately.

    You can also downgrade to GDE 2.4.6 from the developers tab of the plugin repository, which doesn't use any database tables.

    If you don't have time or interest in either of these, I understand. Sorry I couldn't immediately help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.