WordPress.org

Ready to get started?Download WordPress

Forums

Google+ Crossposting
[resolved] Settings won't SAVE - API and G+ID (7 posts)

  1. Jason Koscinski
    Member
    Posted 12 months ago #

    Hi there, I have attempted many times saving my settings from Google API and Google+ to this plugin witout success. I have read the instructions and screenshots. I believe that possibly the plugin is not working with my Google+ ID# because it has an extra "/u/0" preceding. This seems to be different than what is explained in the instructions. I am not sure why I have this extra string in my id.

    http://screencast.com/t/k01gYPa2J

    I have tried saving with the extra string and without.
    I have tried saving with a new API Key as well. And yes it is active.

    Any ideas? I would love to have this plugin working for my G+ posts to my WP Blog, it would save me time!

    Also sometimes after I save, both fields go blank. But sometimes it keeps the API.

    Thanks!!

    http://wordpress.org/plugins/g-crossposting/

  2. doncorso
    Member
    Posted 10 months ago #

    Hey Jason,
    I got exactly the same problem you described with exactly the same Versions.

    I think the problem is the google API key. It seems much more difficulty as described in the short how-to.

    @Sebastian, author of this Plugin:
    Dein Profil sagt, Du kommst aus Berlin, daher schreibe ich auf deutsch weiter, was hoffentlich okay ist.
    Dein Plugin klingt sehr vielversprechend und ich finde die Herangehensweise über einen api-key statt mit benutzername und passwort sehr elegant, bzw. genau richtig.
    Das Erstellen der Google-API erscheint mir aber wesentlich komplizierter, als Du es stichwortartig beschreibst.
    So sieht meine API-ACCESS-Seite aus:
    API-Access-Seite

    und so sieht menie Übersichtsseite aus:
    Overview-Seite

    Wäre schön, wenn Du mir weiterhelfen kannst, ich vermute irgendwo habe ich einen kleinen Fehler drin, einen Haken vergessen oder so....

    Grüße aus Rheinhessen

    DC

    .

  3. Sebastian
    Member
    Plugin Author

    Posted 10 months ago #

    First of all, I have to say I'm very sorry to have missed this thread. In the past, I received an email when someone posted a new support request, but stopped working. Ok, no I subscribed to the RSS feed of the forum. Hopefully, this won't break, too...

    @doncorso Your settings seem to be fine. The steps are:

    1. Login to Google APIs Console at https://code.google.com/apis/console/
    2. Click on "Services", scroll down a lot to find Google+ API and enable it.
    3. Click on "API Access"
    4. On this page, your API key is listed under "Simple API Access"

    I could only imagine that you did something wrong with the wildcards in the refer. Try to set them to "Any referer allowed" to check if that's the problem.

  4. Sebastian
    Member
    Plugin Author

    Posted 10 months ago #

    @Jason So if the values are saved and don't go blank, you got the correct values! Your G+ ID is just the long number, without any slashes.

    So if the values don't go blank, are you able to import something? Please note, only publically visible activities will be imported, not something shared only with selected circles!

  5. doncorso
    Member
    Posted 10 months ago #

    @sebastian: thanks, you were right: "Any referer allowed" did it.

    First manual import did it fine.

    Can I donate somehow?

    s.

    .

  6. Sebastian
    Member
    Plugin Author

    Posted 10 months ago #

    @doncorso: I don't want money. Therefore, I put the homepage of the international red cross as donation link in the plugin description :-)

  7. Sebastian
    Member
    Plugin Author

    Posted 10 months ago #

    marked as resolved to pimp the statistics :-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags