WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Settings > Media > Upload Options Missing (8 posts)

  1. coreymj78
    Member
    Posted 2 years ago #

    My images were not showing up in my posts. Ditto with any plugins (like Excerpts+) I see that this problem has something to do with the "Set Featured Image" in the WP post area. Found out I was "inserting into post" instead of "set as featured image" The reason is because set as featured image was not there due to the fact that I was linking to a URL instead of uploading via my computer. When I found out you are forced to upload via computer (using the default WP uploads directory) if you want to use a featured image, I tried that.

    Now to describe my second issue: as soon as I uploaded the image the usual way into the WP Media Library, the image immediately came up with a broken image logo instead of the actual image and would remain broken when viewing the actual post as well. So I was back to Google trying to see if anyone else had this issue and some folks did and said that they fixed it by adding the full URL path in the WP Settings > Media section... only here's the crazy freaking part: I don't have a Full URL Path input field in my Settings > Media admin page! OMG! Yeah, this is absolutely nuts right? Why would something standard like this be missing from my admin area?

    I tried logging out back in all that jazz and nothing. Here is a screenshot:
    http://www.btdevs.com/assets/misc/media_settings.png

  2. coreymj78
    Member
    Posted 2 years ago #

    Could this have something to do with the fact that I'm on a Multisite install? Is the upload options area normally found in Settings > Media some place different (such as the Network Admin) in a multisite install?

    Thanks.

  3. coreymj78
    Member
    Posted 2 years ago #

    Ok I found it. It was in Network Admin > All Sites > (hover over mysite) > (click edit) > Settings Tab >

    Then under the Settings tab I see two fields in which to type an "Upload Path" and an "Upload URL Path." The Upload Path has this in it:

    wp-content/blogs.dir/2/files

    But the Upload URL Path is blank.

    This must have something to do with why when I try to upload images through the Featured Image or normal Media Browser, they come up broken. What should I put in these two fields?

    Thanks.

  4. webcomms
    Member
    Posted 2 years ago #

    I have exactly the same issue with images appearing broken after uploading into admin and not appearing on the site in preivew. I'm also using multisite.

    My uploads path reads: wp-content/blogs.dir/8/files

    BUT

    when viewing the directory through FTP, the filepath where the images are uplaoding to is different.
    This reads: /wp-content/blogs.dir/8/files/2011/10

    The fileupload URL reads: http://mysitename.org/subdirectoryname/files

    Not sure where to go next?

  5. coreymj78
    Member
    Posted 2 years ago #

    I solved this issue in another thread, but for your benefit I will tell you how I got it working (as I would like other to do for me):

    My problem (and this may not be yours if you set up your Multisite correctly) was that I had skipped a step in setting up my Multisite. On the http://yourdomain.com/wp-admin/network/setup.php page in the 3rd step you will see a code box with this in it:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    Or at least something similar. Make sure you copy/paste this code into your .htaccess file located in the root of your server (normally your public_html folder). If you can't open or edit your .htaccess file, rename it to something like .htaccess2 then try. If you still can't, go into your cPanel on your server and edit / download it that way. This fixed my issue for me and everything is uploading fine.

    As far as the difference between the two upload paths, that is normal as the upload path in the WP site options only needs to read:

    wp-content/blogs.dir/8/files

    ...because WP auto-generates the remaining folder structures (like /2011/10) based on what the date is.

    Hope this helps.

  6. FYI, for better traction, post MultiSite questions in the MultiSite forum http://wordpress.org/support/forum/multisite

    The MultiSite (NOT WPMU!) mavens don't always catch ;em outside of here.

  7. coreymj78
    Member
    Posted 2 years ago #

    By "Not WPMU" are you referring to the fact that some folks mistake the references to the Multisite section of this forum with WPMU Devs? And if so, how would you rate the support given by WPMU Devs? Is it worth the money? If it's not could you point me to a good overall support service for WordPress MU and popular plugins? Thanks.

  8. No I mean WPMU means WordPressMU which is a defunct fork of WordPress. If you say you're using WPMU, it means you're using the pre 3.0 version of the software. After we hit 3.0, it became WordPress MultiSite :)

    (I cannot speak for WPMUDev - Don't use 'em myself.)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags