WordPress.org

Ready to get started?Download WordPress

Forums

Latest Tweets Widget
[resolved] Settings Link Gone (8 posts)

  1. nsmith7989
    Member
    Posted 11 months ago #

    Looks like a good plugin, but I have no way to activate it. There is no place where I can add the Consumer Key and Consumer Secret. Under settings, with the plugin activate, there is nothing.

    http://wordpress.org/plugins/latest-tweets-widget/

  2. timwhitlock
    Member
    Plugin Author

    Posted 11 months ago #

    The plugin adds an option under Settings > Twitter API which points to "/wp-admin/options-general.php?page=twitter-api-admin"

  3. nsmith7989
    Member
    Posted 11 months ago #

    "You do not have sufficient permissions to access this page."

    I assume this is a 3.6 problem, since everyone running 3.5 doesn't seem to have a problem.

    Do you have any other ideas?

  4. timwhitlock
    Member
    Plugin Author

    Posted 11 months ago #

    The plugin uses the manage_options capability which is built into the WordPress administrator privileges system.

    For reference: http://codex.wordpress.org/Roles_and_Capabilities#manage_options

    If it says you don't have permission, then I suspect you don't have this privilege.
    Are you sure your user has sufficient privileges?

    WordPress are very good on not breaking backward compatibility, so I think it's unlikely to be a 3.6 issue. I'm running 3.6 anyway and the option is there.

  5. nsmith7989
    Member
    Posted 11 months ago #

    Thanks for your help!

    It turns out that I was getting a insufficient privileges error because the page did not exist.

    This is technically beyond me, but for whatever reason why I tried to install the plugin from the wp-admin (plugins > add new), it downloaded version 0.2 (or an entirely different plugin?!) which explains all my problems.

    Fixed by installing the correct way per your install instructions (sftp into the wp-content/plugins/). Thanks again for your patience and willingness to answer questions!

  6. timwhitlock
    Member
    Plugin Author

    Posted 11 months ago #

    no problem. You're not the first person to get it mixed up with another plugin.
    There's never been a 0.2 version of my plugin. Current stable version is 1.0.12

  7. Olly - OWMC
    Member
    Posted 9 months ago #

    Add me to the list of people who had to upload it by FTP because installing it via my dashboard lead to "version 0.2" being installed with no Settings Menu link.

    Otherwise looks like a good plugin and I'm using it. So thank you.

  8. timwhitlock
    Member
    Plugin Author

    Posted 9 months ago #

    See the comment above your one.

    There has never been a version 0.2.

    You are commenting on the wrong plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags