WordPress.org

Ready to get started?Download WordPress

Forums

Settings > Miscellaneous WP3? (options-misc.php) (10 posts)

  1. ND
    Member
    Posted 4 years ago #

    Does WP3 have the Settings > Miscellaneous item?

    I'd like to change the settings for <b>Organize my uploads into month- and year-based folders</b> but the menu item isn't there.

    tks

  2. It's under Settings > Media for Single Site and I don't think it's there for MultiSite...

  3. It's not. Multi-site uses the year-month settings for uploads and you can't change it.

  4. drift_dave
    Member
    Posted 4 years ago #

    This appears to break the BuddyPress Groups' avatar upload. Obviously this is beta and it will take a while for plugins to catch up, but it is strange to lose the management of a feature like this.

    Dave

  5. drift_dave, BP is fixing this. This hasn't changed from WPMU, mind you, so that's actually not why it's broken.

  6. Hubert Nguyen
    Member
    Posted 4 years ago #

    Andrea, my WP 3.0 (upgraded from WPmu 2.7) dumps every uploaded files in wp-content/blogs.dir/1/files, and I can't set it to use year-month from the admin UI (the code in options-media.php ). You seem to mention a different behavior in your reply:

    "Multi-site uses the year-month settings for uploads and you can't change it."

    I'd love to get it to use year-month, but I can't, at least from the admin UI. Is there another way, via a config file?

  7. It dumps those files in wp-content/blogs.dir/1/files and them uses year/month folders.

    Your htaccess file then rewrites these URLs to look like
    files/2010/06/myawesomeimage.jpg

    The blogs.dir/1/ gets hidden. The 1 refers to your first site. the second one will have 2, and so on.

    Real life working example:
    http://atypicalife.net/mam/files/2010/06/Putyourhandsin-theair.jpg

  8. Hubert Nguyen
    Member
    Posted 4 years ago #

    Thanks for the reply Andrea. I have found the solution, in another thread:

    It turns out that while the option does not appear in Settings>Media, Super Admin>Sites>Edit has an "Uploads Use Yearmonth Folders" field that I can set to "1" (from "0"). That did it.

    So that means that it is impossible to share media among sub-blogs. Dang! I'll have to duplicate content :(

  9. royalsociety
    Member
    Posted 4 years ago #

    I am thoroughly confused and I consider myself an adequate programmer!!!

    So I've successfully installed WP3 Network version, everything is working - EXCEPT the upload media bit.

    In the instructions I was told to set up a blogs.dir in my wp-content folder, which I did.

    I have Uploads Use Yearmonth Folders set to 0
    and Upload Path set to wp-content/blogs.dir/2/files (for my second blog)

    So why is it trying to move it to uploads??

    "The uploaded file could not be moved to /var/www/vhosts/scienceblogs.org.uk/httpdocs/wp-content/uploads."

    My permissions are correct - in fact I want to shut them down a bit, but I have everything in the wp-content folder set to 777 at the moment trying to isolate this problem.

    Please help!

  10. Go to Super Admin -> Sites and click on 'edit' for your site.

    Check both Upload Path

    I swear there's a second one out there somewhere, so scroll through the whole thing and make sure it's not being weird...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags