WordPress.org

Ready to get started?Download WordPress

Forums

Team Rosters
[resolved] Settings are not applied (5 posts)

  1. skizzopazzo
    Member
    Posted 1 year ago #

    I noticed that changing the settings, the changes are not applied. For example if I change my "college" in "Pro baseball" on your roster changes are not applied. In addition, the link to the page of the players does not work.

    http://wordpress.org/plugins/team-rosters/

  2. Mark O'Donnell
    Member
    Plugin Author

    Posted 1 year ago #

    Hi skizzopazzo,
    I think your problem may be related to the following.

    The (older) roster_type format is somewhat independent of the display settings. That is, if you set the format to baseball-pro, say, like it is here, it will override the display settings. You can see this by changing the above URL to http://shoalsummitsolutions.com/dev/teams/sf-giants/ and you will see a display that matches my display settings.

    If you want to use custom display settings, you need to use a format=custom as a parameter (or omit it as above) to get things to display "properly".

    I believe this is explained in the documentation, although it might be a bit hard to dig out.

    [ Signature moderated. ]

  3. skizzopazzo
    Member
    Posted 1 year ago #

    Hello Mark, I know this one. the problem is that even changing and saving settings, the changes are not applied to the page of the teams. I can not seem to write the database

  4. Mark O'Donnell
    Member
    Plugin Author

    Posted 1 year ago #

    Hi skizzopazzo,
    I looked at your site, and it looks AWESOME, you are almost there! I hope will will share the Italian translation with me when you're done so I can include it in the next release.

    The player gallery looks right to me (??) If it's not please tell me what's wrong. The first thing I noticed was that the link to the single player looked like

    http://www.usdmorianese.com/players/valerio-antonetti/?format=

    and I think you want it too look like

    http://www.usdmorianese.com/players/valerio-antonetti/?format=custom

    which then matches the display on the gallery page.

    This is a bug in the code that I will fix, but there's an easy work-around. My dev site does the same thing but works. Two things you can do that should fix the problem:

    • Make sure the display setting for Roster Table Format is set to Custom.
    • Use http://www.usdmorianese.com/teams/morianese-calcio/?format=custom to bring up the player gallery from your Squadra menu item

    You should only need one or the other, not both. The first option works fine on my dev site, and I tried the second on your site and it seemed to work fine.

    Let me know.

    -Mark

  5. Mark O'Donnell
    Member
    Plugin Author

    Posted 11 months ago #

    I am marking this thread 'resolved' since there has been no activity in over a month. If you have further questions please start a new thread.
    Thanks.
    -Mark

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.