WordPress.org

Ready to get started?Download WordPress

Forums

setting up WordPress on a local host (12 posts)

  1. MarkyBoyOZ
    Member
    Posted 1 year ago #

    Hi,

    I have WAMP installed (PC),
    I drop the wordpress basic folder (3.5) into the the local host
    and start the config process, it will not move past the:-
    create a data base/password/username window.....

    Ideas?

    Thanks.

  2. Tara
    Member
    Posted 1 year ago #

    If you are using permalinks, try resetting your custom permalinks back to the default setting and renaming your WordPress .htaccess file. If that works, then try reading Using_Permalinks before setting a custom permalink structure again.
    Documentation: http://codex.wordpress.org/Using_Permalinks

  3. pvashist75
    Member
    Posted 1 year ago #

    Does it show any error or the site goes blank after configuration page?
    Just go through the documentation at the link below. May be you missed something.
    codex.wordpress.org/Installing_WordPress

    Hope it helps

  4. MarkyBoyOZ
    Member
    Posted 1 year ago #

    I have turned on MySQL in WAMP - this is what i get when I try to auto config - the config file (step2) i am only running 1 x word press site local, i have tried manual conf of config file and i do get an error saying can not find my MYSQL...

    -------------------------------------------------

    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    Try again

  5. MarkyBoyOZ
    Member
    Posted 1 year ago #

    I have read _ codex.wordpress.org/Installing_WordPress
    right down the bottom and have done what has been mentioned above, and ticked the rewtite_modules.....

    i still get the same result....

  6. MarkyBoyOZ
    Member
    Posted 1 year ago #

    my client will not publish anything unless he seeing it first - so use of WAMP.

    All i need to be able to do is create the whole site "in computer", if there is an easier way, id be glad to hear -
    thanks for your help so far.

    Mark

  7. pvashist75
    Member
    Posted 1 year ago #

    I can't give a sure answer but try reinstalling your wamp and phpmyadmin...sometimes they also create problems...just uninstall wamp and phpmyadmin and then try everything again...and use a newly downloaded wordpress install. good luck please tell if it helped you

  8. dang621
    Member
    Posted 1 year ago #

    http://www.scriptol.com/wordpress/installing-wordpress-locally.php

    Try following the steps in the above link. I used these instructions and it seemed to work out okay. The steps are clear and concise.

    Hope this helps.

  9. DaveCoast
    Member
    Posted 1 year ago #

    1. Did you create a Database and note it's name (case sensitive)?

    2. Did you create database specific User (Local/localhost) and note its name(case sensitive) - along with its case sensitive Password? *** you cannot use root ***

    3. Did you grant all privileges for the User created in step 2 to the database in step 1?

  10. westerdaled
    Member
    Posted 1 year ago #

    dang621 , that link looks really useful - what is best Xamp or Wamp?

    I want to do this on a Ubuntu or windows 8 virtual machine ( running under hyper-v). Previously I tried to do this with XAMP on a machine running IIS 7 and entered a whole world of hurt! Yep port 80 contention.

    When I finally resolved this and imported my amended mysql files I kept getting errors due hard coded links in the database e.g.

    I have found 10 occurrences of
    /home/sites/myblog.com/public_html/wp_content....

    Has had anyone else had this issue and is it a case of search and replace or should I install on my local Linux vm

    Also, if say my blog is called myblog.com then to run locally I guess you will need to ensure the the host file points to the local XAMP or WAMP instance and not the myblog.com on the internet.

  11. MarkyBoyOZ
    Member
    Posted 1 year ago #

    The Post below from the kind gentlemen got it right for me.....

    dang621 wrote:

    http://www.scriptol.com/wordpress/installing-wordpress-locally.php
    Try following the steps in the above link. I used these instructions and it seemed to work out okay. The steps are clear and concise.
    Hope this helps.

    Read this post on the forums: http://wordpress.org/support/topic/setting-up-wordpress-on-a-local-host?replies=8#post-3697189

    You're getting this email because you subscribed to 'setting up WordPress on a local host.'
    Please click the link above, login, and click 'Unsubscribe' at the top of the page to stop receiving emails from this topic.

  12. westerdaled
    Member
    Posted 1 year ago #

    Hi MarkyBoyz/dang21

    So far so good on XAMP - thanks for your help. I have all my posts imported. I don't however have my child theme(s) and the myriad of plugins I use. What is the best strategy for getting these on to the local install ... I guess I need to ftp over the entire

    /wp-content/themes
    /wp-content/plugins

    Is there anything else.

Topic Closed

This topic has been closed to new replies.

About this Topic