WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] setting up subdomain for wordpress, images "broken" when subdomain entered (6 posts)

  1. ferretgr
    Member
    Posted 6 months ago #

    Hi folks,

    My wordpress install (hosted on a Windows Plesk IIS installation through Godaddy) at http://gerryryall.ca/wordpress/ seems to be working fine, all images and links working etc. To get permalinks working I had to create a web.config file, but that's taken care of. My next task was to try to set up a nicer URL: http://hikingnewfoundland.gerryryall.ca is the one I tried. Anyhow, when I head to that link, the blog appears fine, ie. the theme and CSS are working, but the images all appear as broken links.

    My google-fu tells me that this is an URL redirect issue, similar to the permalinks issue. My searches lead me to believe that I need to add the equivalent of what would go into an .htaccess file under an Apache/Linux install (ie. the information contained here: http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite) into my web.config file, but I can't figure out exactly what I need to put in there, and my skills are at too low a level to properly create the code from scratch. I'm sure that this isn't a unique problem based on my googling, so hopefully someone can help me out!

    By all means, let me know if you need more into!

    Thanks in advance,
    Gerry

  2. webbrewers
    Member
    Posted 6 months ago #

    If the sub domain is pointed at the right directory (in plesk) and you've adjusted the site urls in settings ยป general, the image links should be corrected. Any absolute urls or serialized references wouldn't work because the base url has changed, and would have to be updated in the database.

  3. ferretgr
    Member
    Posted 6 months ago #

    Hi Webbrewers,

    Thanks for your assistance. I have the subdomain pointed to root/httpdocs/wordpress, which is where my wordpress install lies, and it seems to be pointed in the right place given that the rest of the blog elements load, ie. the theme, text, etc. Only the images are missing. I remembered reading that the "Home" and "Site URL" needed to be set properly, and thought I had tried every iteration, but apparently I had not: when I set the "WordPress address" to "hikingnewfoundland.gerryryall.ca" and set the Site address to "gerryryall.ca/wordpress", that seems to have resolved the issue!

    Thanks Webbrewers!

    Cheers,
    ferretgr

  4. ferretgr
    Member
    Posted 6 months ago #

    Actually, it seems like I'm still having some issues... Trying the link on different machines and in fresh browsers has revealed a couple of images that seem to refuse to load, ie. the background image. Any idea why a specific image might get hung up?

  5. webbrewers
    Member
    Posted 6 months ago #

    Check the urls:
    "Any absolute urls or serialized references wouldn't work because the base url has changed, and would have to be updated in the database. "

  6. ferretgr
    Member
    Posted 6 months ago #

    Problem solved. It was the "hotlink protection" at Godaddy... I guess it was seeing hikingnewfoundland as making use of a hotlink. Thanks again for your help!

Reply

You must log in to post.

About this Topic