WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Setting up for permalinks on local test server (7 posts)

  1. ConCity
    Member
    Posted 3 years ago #

    Hello fellow word pressers, I am having trouble getting permalinks to work on my local test server. Any help with this would be greatly appreciated.
    Setup: I'm not using the WAMP AIO. I set up Apache MySQL and PHP myself running on Windows 7 ultimate. and utilizing virtual hosts.
    Things I've tried: Uncommenting mod_rewrite in httpd.conf altering the .htaccess file in the root of the wp install. I've searched for answers to this on google and in the codex, and have had no luck finding a fix.
    Permalinks work fine on the live server.
    Thanks in advance for any help!

  2. Tara
    Member
    Posted 3 years ago #

    see if info here can help you: http://codex.wordpress.org/Using_Permalinks

  3. ConCity
    Member
    Posted 3 years ago #

    thanks t-p. I reread the info there, made sure I did everything correctly, and "pretty permalinks" still arent working. However i was able to add index.php before /%category%//%postname%/ that got it going with the exception that I now have index.php before the permalinks which won't match the live server.
    From reading what you sent to me I am led to believe that it is a problem with apache running on windows.

    "Pretty" permalinks usually require mod_rewrite, and IIS (common on Windows servers) does not support mod_rewrite. (If you are using Apache 2.0.54, on Windows, mod_rewrite may work, provided it is enabled in apache\conf\httpd.conf.)

    http://codex.wordpress.org/Using_Permalinks
    Thanks

  4. Tara
    Member
    Posted 3 years ago #

    From reading what you sent to me I am led to believe that it is a problem with apache running on windows.

    that's my understanding.

  5. ClaytonJames
    Member
    Posted 3 years ago #

    If mod_rewrite is functioning, you either need to enable AllowOverride globally in httpd.conf, or enable it per virtual host container to use pretty permalinks.

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    You may also want/need to enable:

    Options Indexes FollowSymLinks

    Either globally, or in the virtual host container. Consult the apache documentation for details.

  6. ConCity
    Member
    Posted 3 years ago #

    Thank you very much Clayton, that got it fixed, and working perfectly. To be more specific I had overlooked setting it properly for the vhosts.
    #
    AllowOverride All

    I really appreciate your help, hopefully I'll be able to return the favor one day. !!

  7. ClaytonJames
    Member
    Posted 3 years ago #

    It's an easy thing to overlook. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.