WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Setting theme width in the CSS (6 posts)

  1. xiaozhu
    Member
    Posted 6 years ago #

    Hi there,

    I'm having a hard time with my theme's layout.

    Here is my blog : Correr Es Mi Destino

    I have two columns, both with fixed width (since they have pictures, I don't want them to resize) :

    - Left column : 100px
    - Right column : 235px
    - Header is 1024px width

    Anything else can be flexible.

    For now, my theme is showing up fine in 1024px (and above) screen resolution, but in 800x600, the right sidebar plunges at the bottom.

    I'm looking for a layout similar to the one I used in Blogger : My old blogger blog

    In this one, everything was fixed width and people with small screen resolution just had to scroll a bit.

    I experimented with various width, fixed or not, in the CSS (for columns, content etc.) but I can never get a good result. I've been stuck with that for a while, so I'd love if you can give me a hand or point me to the right direction.

    I believe you guys can see my CSS, so I won't do the copy-paste mistake ;-)

    Thanks a lot !

  2. adeelshahid
    Member
    Posted 6 years ago #

    what i know of, if you need to make left and right column a certain size and let the middle column be of flexible width, then you got to use percentage for all 3 columns.

    If you use px width's for 2 columns and have the middle flexible it won't work.

    Either you have all the 3 columns px with defined width or you need to have all the 3 columns with a % width.

    So that your blog layout does'nt break.

  3. xiaozhu
    Member
    Posted 6 years ago #

    Makes sense, thanks for stepping in !

    I'm gonna try with all fixed.

    Any other thoughts ?

  4. adeelshahid
    Member
    Posted 6 years ago #

    nopes

    let me know how it works out.

  5. adeelshahid
    Member
    Posted 6 years ago #

    in the write page,

    check right column, there is Discussion box, expand it and uncheck the Allow Comments checkbox that should resolve the problem.

  6. xiaozhu
    Member
    Posted 6 years ago #

    I made it with the help of a friend. Thanks for the advice !

Topic Closed

This topic has been closed to new replies.

About this Topic