WordPress.org

Ready to get started?Download WordPress

Forums

WP Google Maps
[resolved] Setting the zoom level - shortcode (10 posts)

  1. aaronbennett2097
    Member
    Posted 6 months ago #

    Know you've probably answered this more times than you can remember, but I just cannot get the map to zoom into a specific place.

    I deleted the London marker, then added my own and clicked on EDIT LOCATION zoomed into a bit, then clicked SAVE MARKER LOCATION, then again on SAVE MAP.

    But when I view the map - inserted into the template via php, it just shows the world map - it shows the marker but zoomed all the way out.

    I think it's because I need to add some code to the shortcode, but can't find any info on shortcode variables anywhere.

    Hope you can help - looks like a great plugin.

    https://wordpress.org/plugins/wp-google-maps/

  2. WPGMaps
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Aaron
    Sorry for the delay.
    The steps you took are the correct steps. There's no additional fields required for the shortcode other than just the "id".

    Can you please send me a link to the map so I can debug?

    Kind regards
    Nick

  3. aaronbennett2097
    Member
    Posted 6 months ago #

    Hi Nick.

    Thanks - the url is http://imaginationpr.co.uk/get-in-touch/

    I was wondering what I was doing wrong, but hopefully you can get to the bottom of it for me - this plugin is PERFECT apart from that!

  4. WPGMaps
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks Aaron

    OK so just to be clear, when you were in the map creation page, did you set your preferred zoom level on the map that displays there and then press "save map"?

  5. aaronbennett2097
    Member
    Posted 6 months ago #

    Here's the stages I took...

    1 - go to Maps and click edit on the original map as I can't add a new map.

    2 - Changed Map Name, changed width to 100%; height 100%

    3 - Deleted London marker and added new marker of my address.

    4 - clicked Edit Location and zoomed in / panned around to the view I want and clicked Save Marker Location.

    5 - back in the Map Settings page I click Save Map.

    I can't find anywhere that specifies the zoom level APART from in the Edit Location page.

    Hope that helps, appreciate your help mate!
    Aaron

  6. WPGMaps
    Member
    Plugin Author

    Posted 6 months ago #

    Aaaah I see.
    On the map map, after step 2 (the main map is just below those settings), use your mouse scroll wheel or the controls in the map to adjust the zoom setting then press "Save map".

    The "Edit location" is purely for dragging and dropping markers to specific locations and does not adjust the main map's zoom level.

  7. aaronbennett2097
    Member
    Posted 6 months ago #

    I can't see any main map on my screen - I can see the tip under the save map button, but no actual map - trying to attach a screenshot for you.

  8. aaronbennett2097
    Member
    Posted 6 months ago #

  9. WPGMaps
    Member
    Plugin Author

    Posted 6 months ago #

    Ah well there's the issue :)
    Please email me at nick@wpgmaps.com so I can help you better from there

  10. aaronbennett2097
    Member
    Posted 6 months ago #

    Firstly, thanks for all your help Nick!

    For anyone else having the same problem and not seeing the map underneath the Save Map button - change height from % to px - the map is then displayed, you can set the zoom level and then change back to height %.

    Hope that makes sense to all.

    Top notch plugin!!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.