WordPress.org

Ready to get started?Download WordPress

Forums

Efficient Related Posts
[resolved] set_time_limit() error (6 posts)

  1. Chris
    Member
    Posted 7 months ago #

    Hi, after upgrading to version 0.40 I get the following error:
    Warning: set_time_limit() has been disabled for security reasons in /.../wp-content/plugins/efficient-related-posts/efficient-related-posts.php on line 337
    triggering a "headers already sent" error.

    http://wordpress.org/plugins/efficient-related-posts/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 7 months ago #

    Hey Chris, if your site has very many posts/tags, you won't be able to process all the relations without extending out the time limit there. You also shouldn't have display_errors on for a production site (log them, but don't display them). Having said that, I can suppress the warning so that you don't get a headers sent error. The fix will be in the next release whenever that is (0.4.2 or maybe 0.5.0 depending), but you can download a zip with the fix included here: https://github.com/OpenRange/efficient-related-posts/archive/master.zip

  3. Chris
    Member
    Posted 7 months ago #

    Thank you! (Unfortunately on all shared hosting sites that I use I cannot change display_errors.)

  4. Aaron D. Campbell
    Member
    Plugin Author

    Posted 7 months ago #

    What shared host do you use? Usually they have it OFF by default and you have to turn it ON.

  5. Michal N.
    Member
    Posted 18 hours ago #

    Hi Im same problem with version 0.4.1. . Can You help me?

    Warning: set_time_limit() has been disabled for security reasons in ...../www/wp-content/plugins/efficient-related-posts/efficient-related-posts.php on line 337

    Warning: Cannot modify header information - headers already sent by (output started at .../www/wp-content/plugins/efficient-related-posts/efficient-related-posts.php:337) in /data/web/virtuals/64498/virtual/www/wp-admin/post.php on line 235

    Warning: Cannot modify header information - headers already sent by (output started at ..../www/wp-content/plugins/efficient-related-posts/efficient-related-posts.php:337) in /data/web/virtuals/64498/virtual/www/wp-includes/pluggable.php on line 1121
    This warning info is after save post.

  6. Michal N.
    Member
    Posted 16 hours ago #

    I have 311 posts and 97 tags. http://www.k-domu.cz/

Reply

You must log in to post.

About this Plugin

About this Topic