WordPress.org

Ready to get started?Download WordPress

Forums

HTML Import 2
[resolved] set_time_limit() disabled for security reasons in line 325 . . . (3 posts)

  1. Dragons Eye
    Member
    Posted 1 year ago #

    I don't believe this is so much an error with the plugin in as much as my hosting service's "security" constraints.

    Is there a way around this that will not compromise any security?

    I am seriously needing a good HTML importer for my blog, and this one looked perfect for the job.

    Any ideas?

    I am fairly knowledgeable in PHP if there is a "fix" you wish to suggest.
    ( and I forgot which module this occurred from before I uninstalled the plugin. )

    UPDATED:

    Here is the EXACT error (warning):

    Warning: set_time_limit() has been disabled for security reasons in /home/a8268343/public_html/members/wp-content/plugins/import-html-pages/html-importer.php on line 325.

    Also, content of page(s) are not imported. Leaves an empty page instead.

    Any help appreciated, thanks!

    http://wordpress.org/extend/plugins/import-html-pages/

  2. Stephanie Leary
    Member
    Plugin Author

    Posted 1 year ago #

    It's not exactly a security issue; it's just that your host has taken steps to ensure that you don't hog the memory and interrupt other users' service. Just comment out line 325.

    If your content is blank, you've chosen the wrong tag/region to import. See the user guide.

  3. Dragons Eye
    Member
    Posted 1 year ago #

    Unfortunately,

    On later testing, it did the exact same thing on my own local-host set up. I have no such settings on my XAMPP installation.

    This seemed to do this on every HTML page (no matter the size) that I tried to import. Therefore, I just settled to manually copy-and-paste those pages from another editor (like my page editor).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.