WordPress.org

Ready to get started?Download WordPress

Forums

Set up with IIS not working (13 posts)

  1. glider_pilot
    Member
    Posted 9 years ago #

    Installed PHP with the automatic install package for iis version i have.

    Then I installed Mysql
    then create database blog
    then did a use blog

    Then modified the PHP-config file as :

    ?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/

    // ** MySQL settings ** //
    define('DB_NAME', 'blog'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', 'deb'); // ...and password
    define('DB_HOST', 'localhost');

    When I try to run the admin install php it just tells me page can not be displayed.

    ISS application maping looks to be corect for the php.

    Thanks in Advance
    Tim

  2. TechGnome
    Moderator
    Posted 9 years ago #

    Will a mod help this poor soul out by REMOVING THE PASSWORD before some one comes along and grabs it.

    It is NEVER A GOOD idea to post that....

    tg

  3. SuperSpiker
    Member
    Posted 9 years ago #

    I noticed that too.

    a better solution would be that glider_pilot changes his mysql user and password (and make it longer than 3 chars) asap.

  4. glider_pilot
    Member
    Posted 9 years ago #

    That is not my password. I just put something in there.
    Well I got a little more going I rebooted the whole system and now it is teeling me there is sometihng wrong with my config file user name or password. I am not sure what I am doing with mysql or that i have it running correctly so I am going to go do some more reading.
    Glider_Pilot

  5. SuperSpiker
    Member
    Posted 9 years ago #

    What are the specific messages that the MySQL server is giving you?

    Those can help us to help you better.

  6. glider_pilot
    Member
    Posted 9 years ago #

    MySQL is not giving me any error msgs.
    Here is the msg I get when i try to run the instal.php

    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.

    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

  7. RustIndy
    Member
    Posted 9 years ago #

    Sounds like you're using MySQL 4.1 with PHP4, yes? That takes a little tweaking. Let us know what versions of PHP and MySQL you're using.

  8. glider_pilot
    Member
    Posted 9 years ago #

    Yes MySQL is ver 4.1 and it looks like PHP is version 4.

  9. glider_pilot
    Member
    Posted 9 years ago #

    Ok I have figured out that Wp is not connecting to mysql correctly. I can access mysql using the command line and using my password for the root account. But this account when placed in the wp-config it will not connect. I continue to get the wrong password screen. I think I am probably doing something wrong with mysql. I have spent many hours reading the mysql doc trying to figure it out. But I can connect via the command line on any of the accounts I created.
    Help Please

  10. RustIndy
    Member
    Posted 9 years ago #

    PHP4 does not like MySQL 4.1 because MySQL 4.1 uses a newer authentication than PHP4 has.

    To workaround, either downgrade to MySQL 4.0 (if you can), upgrade to PHP5 (if you're using the 1.5 betas - WP 1.2 doesn't like to install with PHP5), or perform the following (using PHPMyAdmin or directly to the database itself):

    In your MySQL ini file (usually this is called "my.ini" I think), in the [MySQLD] section, add old-passwords on a line by itself.

    Now restart MySQL and connect to the database (command line, PHPMyAdmin, MySQL Query Browser - whatever tool floats yer boat), and:

    use database blog;
    SET PASSWORD FOR -> "root" = OLD_PASSWORD("changeme");

    Assuming that works (it did for me - had this problem getting Mambo to work, but I run WP1.5 on PHP5 with MySQL 4.1), your blog should start working :)

    And please don't use "root" to login. Create a new account. If you create a new user after restarting MySQL with the "old-passwords" line in "my.ini", you won't have to do the second step above (I don't think - if it doesn't work, then do the query).

    Good luck :)

  11. glider_pilot
    Member
    Posted 9 years ago #

    Thanks,
    I downgraded mysql and all came up working right off the bat once i put the accounts in it.
    Thanks for the Info

  12. glider_pilot
    Member
    Posted 9 years ago #

    Thanks all that responded. I am setting this up only to learn something new. But after many hours of working with it. I think I might install it on my web server and see if it gets used. That way I can continue to learn about it and mysql at the same time.

    Thanks

  13. RustIndy
    Member
    Posted 9 years ago #

    Glad to help :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.