WordPress.org

Ready to get started?Download WordPress

Forums

Simple 301 Redirects
Set-up 3000+ Redirects, Worked but Stopped Now (3 posts)

  1. Jeewan
    Member
    Posted 5 months ago #

    Hello, We setup over 3000+ redirect by manually copying each link from the site we moved and then created the csv file in the format and uploaded. All was well and the links were redirecting when checked randomly. Now, it has come to my notice that none of the links are redirecting. I use MAXCDN and total cache plugin, is there any way this could be an issue, if not, kindly shed some light as to why the plugin is not working.

    Regards and thank you for your time in development and support, much appreciated.

    http://wordpress.org/plugins/simple-301-redirects/

  2. scottnelle
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Jeewan,
    Are the redirects you've configured still showing up in the interface under Settings > 301 Redirects? In some cases PHP has trouble reading serialized strings with more than 500 entries. It's possible a PHP update at your web host is causing problems. I'm afraid I'm not certain which versions of PHP have this problem, as of yet.

    I have found in some cases that caching plugins like total cache can prevent my plugin from doing it's job. The resolution is usually to clear the cache, and then turn the caching plugin off and back on again. This will allow my plugin to get top priority for any requests that are stored in the plugin.

    Let me know if that doesn't solve the issue for you and I can try to help you debug further.

  3. Jeewan
    Member
    Posted 5 months ago #

    Hi Scott,

    Thank you for the response. Yes, all the redirects show in the plugin interface with both the original and the redirect link intact. I have contacted the Cache plugin support and CDN support, we investigated by turning off the plugin as well as CDN but still the redirects did not work.

    I tried your suggestion of clearing cache and turning on the cache plugin off but that did not work out. Please let me know if there is any other way to get this to work.

    Appreciate your time.
    Jeewan

Reply

You must log in to post.

About this Plugin

About this Topic