WordPress.org

Ready to get started?Download WordPress

Forums

Set Language in worpress instaled in Debian (4 posts)

  1. Guta
    Member
    Posted 6 years ago #

    Hello.
    I have installed wordpress 2.3.2 in debian with apt method:
    aptitude install wordpress

    I want to put it in Spanish language. I have downloaded the es_ES.mo file and put it in wp-content/languages/

    In debian instaled way /usr/share/wordpress/wp-config.php is a link to /etc/wordpress/wp-config.php and wp-config.php contents:
    <?php
    /** WordPress's Debianised default master config file
    Please do NOT edit and read about how the configuration works in the README.Debian
    **/

    #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435289
    #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440572 (underscores, not dashes)
    $debian_server = preg_replace('/:.*/', "", $_SERVER['HTTP_HOST']);
    $debian_file = '/etc/wordpress/config-'.strtolower($debian_server).'.php';

    if (!file_exists($debian_file)) {
    header("HTTP/1.0 404 Not Found");
    echo "404 Not found";
    }

    require_once($debian_file);

    define('ABSPATH', '/usr/share/wordpress/');
    define(’WPLANG’, ‘es_ES‘);

    require_once(ABSPATH.'wp-settings.php');
    ?>

    I have put define(’WPLANG’, ‘es_ES‘);
    in it but it dont set my wordpress in spanish.

    There is another file called /etc/wordpress/config-www.myweb.org.php with:
    <?php
    define('DB_NAME', 'myname');
    define('DB_USER', 'myuser');
    define('DB_PASSWORD', 'mypassword');
    define('DB_HOST', 'localhost');

    $table_prefix = 'wp_';

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    ?>

    I have put define(’WPLANG’, ‘es_ES‘); in it too, but nothing happens.

    ¿How can i put my blog in spanish language?

    Thank you very much.

  2. moshu
    Member
    Posted 6 years ago #

    define(’WPLANG’, ‘es_ES‘);
    The quotes in this line are wrong! Use straight quotes ['] not "curly" ones...

  3. Guta
    Member
    Posted 6 years ago #

    Yes, i put straight quotes
    define('WPLANG', 'es_ES');
    But still not working :(

    Where i can define it?

  4. moshu
    Member
    Posted 6 years ago #

    If you corrected the quotes - then I don't know.
    We don't support server setup questions here. Try a debian forum!

    If the server is set up correctly, the installation is easy...

Topic Closed

This topic has been closed to new replies.

About this Topic