WordPress.org

Ready to get started?Download WordPress

Forums

set language (7 posts)

  1. Camilla
    Member
    Posted 9 years ago #

    I have tried to install swedish language on my blog. Have followed the instructions to the last letter. set wplang to 'sv_SE' and made a new folder in wp-includes called languages where I installed the ISO mo file. Yet the blog is shown in english language.

    What should I do??

    Greatful for any suggestions

    Camilla

  2. jalenack
    Member
    Posted 9 years ago #

    Is the entire site (including the admin section) in English, or just the blog part?

    Some theme developers don't add the necessary hooks for language packets to do their duty. So are you using the default Kubrick theme that came with WordPress? or something else? A link to your site would be handy. Good luck.

  3. Camilla
    Member
    Posted 9 years ago #

    The entire site is in English. I am currently using another theme than the default. But I tried the language setting with default as well - no changes.

    You'll find my blog here: http://www.adnotam.se/blog

    Camilla

  4. moshu
    Member
    Posted 9 years ago #

    Hmmm... Camilla, you said:
    I installed the ISO mo file
    yet your site has utf-8 encoding. You should try the utf-8 .mo file, too.
    Another question: what is the exact name of the .mo file on your server?

  5. jimithesaint
    Member
    Posted 9 years ago #

    Camilla, I have the same problem with sv_SE localization with 1.5.1.3, maybe we can try to work it out together.

  6. Camilla
    Member
    Posted 9 years ago #

    Yes, lets try to work this out. I am desperate to find a solution. Will try to use the utf-8 file now.

    Moshu: the exact name of the iso file I was talking about is sv_SE.ISO-8859-1.mo Should I state the entire file name in the wp-config file?

  7. Camilla
    Member
    Posted 9 years ago #

    Ha,ha! I made it! I downloaded the utf-8 mo.file for Swedish language; put it in wp-includes/languages. After that I changed the language setting in the wp-config file to sv_SE.uft-8 that did the trick. Both the blogtemplate plus the administrator´s pages are in Swedish.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags