WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Set callback to my URL; Twitter Widget Pro STILL not Authorizing (13 posts)

  1. GradingGirl
    Member
    Posted 1 year ago #

    Hi Aaron!

    Consumer key and consumer secret is set; I set up the callback back to my URL.

    Twitter Widget Pro still states "Must Authorize" Twitter account. When I press on that notification, I am flashed back to same screen.

    . . . . hope I was correct in starting a new thread. Thanks in advance for your help!

    Theresa

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Alahin
    Member
    Posted 1 year ago #

    I just noticed the next message:
    https://dev.twitter.com/blog/planning-for-api-v1-retirement

    This might have something to do with it?

  3. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    GradingGirl: Once you have set up the Consumer key/secret, there's another box on the settings page titled "Authenticated Twitter Accounts" (it's the top box unless you've rearranged them). In that box is a button labelled "Authorize New Account". If you click that you'll be taken to Twitter to Authorize your newly created application for your Twitter account.

  4. michielvanerp
    Member
    Posted 1 year ago #

    Aaron, same problem here.

    Entered consumer key/secret, filled the callback field with a valid url to my own domain but clicking the 'Authorize New Account' just refreshes the settings page, it does not redirect me to Twitter. I've tried it with and without a 'signed in' status with Twitter. The part 'Authenticated Twitter Accounts' stays empty.

    Any ideas?

  5. ebrumley
    Member
    Posted 1 year ago #

    Me three. Exact same thing as michielvanerp and GradingGirl. There is no "Authenticated Twitter Accounts" in my settings page.

  6. ebrumley
    Member
    Posted 1 year ago #

    Hey, not sure if related, but in settings (in dev.twitter.com), I changed application type to read only, callback URL to the homepage of my website, and checked "Allow this application to be used to Sign in with Twitter".
    After a few minutes, I went back to my WP dashboard and my account was available for authentication "Authorize new account". Then I did the "Sign in to twitter" from that link in WP dashboard and I'm back up.

  7. GradingGirl
    Member
    Posted 1 year ago #

    ebrumley - You rock!! Thank you. YOU solved my problem; thank you for clarifying where that Twitter settings is located (dev.twitter.com). Program-illiterate folk like me need every detail spelled out. :-)

  8. Mr_Cre8ive
    Member
    Posted 1 year ago #

    Exact same problem here. Solution?

  9. Mr_Cre8ive
    Member
    Posted 1 year ago #

    I figured it out!! After receiving your "Access Token" and "Access Token Secret" from the dev.twitter website, you must then COPY and PASTE those codes back into the "Consumer Key" and "Consumer Secret" fields (respectively) on the Twitter Widget Pro settings page in WordPress. The same place that you originally posted the first set of codes. Then, click "Authorize". Hope this helps... It worked for me.

  10. gkvwezep
    Member
    Posted 1 year ago #

    Hmm all this tips will still not work for me…

  11. VeloVet
    Member
    Posted 1 year ago #

    This is not resolved. I can't authorize; have tried all tips above.

    Any other ideas?

  12. It's resolved because the plugin author or the original poster says it's resolved.

    If you have this problem and trying ebrumley's solution didn't fix it for you maybe you want to try starting your own thread? There might be something different about your setup than GradingGirl's.

    http://wordpress.org/support/plugin/twitter-widget-pro#postform

  13. raisonon
    Member
    Posted 1 year ago #

    I got this work by

    - setting to read only
    - making sure i added www. on my callback url
    - refreshed dev. to discover my consumer keys changed
    - added it (made sure I clicked update before authorize)

    and it worked.

    spent 30mins on that and a very random permutation fixed it. Sorry I wasn't more scientific!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic