WordPress.org

Ready to get started?Download WordPress

Forums

Serving WordPress from OS X? (29 posts)

  1. IronMac
    Member
    Posted 8 years ago #

    Thanks to Michael Doig and Textpattern's excellent tutorials I have managed to install WP using MAMP on my machine. My problem is now how to serve my blog to the outside world?

    I have a DSL account which means I have a dynamic IP address. I went to DynDNS, signed up for an account and account name. Problem is that whenever someone tries to access my site they don't see anything. The connection never happens.

    I don't know what the problem is but here is my setup:

    Mac OS X 10.3.9
    Linksys WRT54G
    Apache and MySQL servers running according to MAMP

    I think that my problem might be in the routing table for my router but I don't know if that is the case or not. Any assist would be greatly appreciated. Thanks!

  2. VaamYob
    Member
    Posted 8 years ago #

    what's your dyndns domain name ?

    i.e. yourblog.dyndns.org

  3. IronMac
    Member
    Posted 8 years ago #

    it's ironmac.blogdns.com

  4. VaamYob
    Member
    Posted 8 years ago #

    $ telnet ironmac.blogdns.com 80
    Trying 64.229.201.62...

    Maybe your router is blocking port 80 ?

  5. VaamYob
    Member
    Posted 8 years ago #

    It's been a while since I messed with my WRT54G, but if I remember correctly, all I had to do was assign my server a static ip address (i.e. 192.168.2.1), then route requests for port 80 to my server's ip address.

  6. IronMac
    Member
    Posted 8 years ago #

    That is what I thought too but my routing table settings are:

    http 80 to 8889
    apache 8888 to 8888
    mysql 8889 to 8889

    This is for Port Range Forward...from what I can tell, I'm wide open at the moment.

  7. IronMac
    Member
    Posted 8 years ago #

    Ahhh...that might be it!!!

    "It's been a while since I messed with my WRT54G, but if I remember correctly, all I had to do was assign my server a static ip address (i.e. 192.168.2.1), then route requests for port 80 to my server's ip address."

    How do u do that?

  8. VaamYob
    Member
    Posted 8 years ago #

    I have no clue how you assign a static ip address in OSX.

    Do you need help in forwarding to the server ? I can walk you through that; if you can set your server up with a static ip address.

  9. IronMac
    Member
    Posted 8 years ago #

    Does Apache server need an IP address, dynamic or otherwise? Could that be the problem? Thanks!

  10. VaamYob
    Member
    Posted 8 years ago #

    oh boy, when you say "server" do you mean "host", the physical machine ?

    The host machine has to have a static ip address. Apache has to be configured to listen/accept requests for that address/port combination.

  11. IronMac
    Member
    Posted 8 years ago #

    I'm currently running Apache server on my machine and I thought that it was properly set up?

  12. IronMac
    Member
    Posted 8 years ago #

    VaamYob...would you try ironmac.blogdns.com again?

    I went to a my System Preferences -> Sharing -> New and set up a service there.

  13. VaamYob
    Member
    Posted 8 years ago #

    Still no luck trying to access the server.

    We can start there.

    What's the apache machine's ip address ?

  14. IronMac
    Member
    Posted 8 years ago #

    Rats...I don't know Apache's IP addy...where can I find that?

  15. VaamYob
    Member
    Posted 8 years ago #

    I meant, what's the ip address of the machine on which you're running apache ?

  16. IronMac
    Member
    Posted 8 years ago #

    According to System Preferences, my machine has the IP address of 192.168.1.100.

  17. VaamYob
    Member
    Posted 8 years ago #

    ok,

    now go to your linksys router and forward port 80 to 192.168.1.100 port 80

    Do you use some sort of instant messenger service ?

  18. IronMac
    Member
    Posted 8 years ago #

    Ok, let me get this straight, for:

    Application: http
    Start: 80
    End: 80
    Protocol: Both
    IP Address: 192.168.1.100
    Enable: Checked

  19. IronMac
    Member
    Posted 8 years ago #

    And yes, I use MSN Messenger...look for IronMac@hotmail.com or simply IronMac.

  20. VaamYob
    Member
    Posted 8 years ago #

    yeap, that should do it.

    (but it doesn't because I still can't access your site.)

    are you online (msn)? I don't see you as being active.

  21. IronMac
    Member
    Posted 8 years ago #

    Yep, I'm on Messenger right now, what's your contact info? Maybe I can give it a shot. Man, I'm becoming pretty disappointed with hosting this on my own.

  22. VaamYob
    Member
    Posted 8 years ago #

    just sent you an email with my msn screen name.

  23. IronMac
    Member
    Posted 8 years ago #

    Ohh...I'm so sorry...but it's trek790 at hotmail.com! Duh! The screen name is IronMac.

  24. scottfeldstein
    Member
    Posted 8 years ago #

    I run WP on osx behind a router. If you want 1 on 1 help, feel free to email me at scott at scottfeldstein.net

  25. emeff
    Member
    Posted 8 years ago #

    @IronMac or @scottfeldstein

    please write a how-to if you are successful!

    Thankxx,

    emeff

  26. VaamYob
    Member
    Posted 8 years ago #

    Not exactly a howto but general steps are:

    1. make sure mamp is running on port 80
    http://www.mamp.info/en/help/faq/#83

    2. make sure your host has a static ip address
    http://www.portforward.com/networking/static-Mac10.4.htm

    3. then configure your router to forward requests for port 80 to your new static ip address' port 80
    http://www.portforward.com/english/routers/port_forwarding/Linksys/WRT54G/HTTP.htm

    4. finally, IMPORTANT pray that it works.

  27. torifile
    Member
    Posted 8 years ago #

    Good grief. You guys need to start at 0. Your machine's IP address may be 192.168.1.2 or whatever, but that's the IP addy your router is assigning to you. You need to find out the IP address the rest of the world sees. To do that, you can go to whatismyip.com and it'll tell you.

    Since your *router* is actually at that IP address and it's just directing traffic from the computers on the network, you have to tell the router *where* to send requests for the webpage. That's where port routing/forwarding comes in. You'll have to read your particular router's manual to find out how to do this exactly, but most routers have a web-based admin (usually 192.168.1.1) and you set it up there.

    There are a couple of caveats to running your own server. The first is that you likely don't have a static IP address with your ISP, so your IP may change. As a result a normal http://www.myserver.com addy won't work because DNS servers won't know where to look. To get around this, you can get a dyndns.org address. You'll have to figure that one out for yourself, but it's pretty straightforward.

    Setting up Apache on OS X requires nothing more than checking "web sharing" in the System preferences. You don't need to worry about ports or anything because a standard WP install will run on port 80. Email me at torifile at mac dot com if you have any questions.

  28. IronMac
    Member
    Posted 8 years ago #

    Scott or torifile, I'm going to be on MSN Messenger at IronMac (trek790 at hotmail.com) Saturday afternoon EST so if either one of you (or anyone else for that matter!) is free to help out that would be great.

    VaamYob was a great help yesterday in determining that the problem really isn't with WP or Apache server. In fact, it turns out that, yes, Apache is running fine and is serving up WP. The problem seems to be that my router isn't letting the outside world in. (Great for security...bad for serving up webpages.)

    Need to configure the router to send requests for 64.229.201.62 (ironmac.blogdns.com from DynDNS.com) to my machine on the internal network.

    Anyways, like I said, I will be on this afternoon and checking posts here too. Thanks everyone!

  29. IronMac
    Member
    Posted 8 years ago #

    Update...after a very brief exchange with Michael Doig, it turns out that MAMP is only meant to serve up WP locally...not to serve up your weblog to the outside world.

    If I want to serve up WP to the outside world then I will have to enable Apache, MYSql, and PHP on my system. Luckily, there are a couple of tutorials out there that I (or you) may want to try our hands at. The first is from Nerd Vittles (who is actually using WP) and the other is from O'Reilly (MacDevcenter.).

    If anyone wants to share their experiences with doing this please do here. If not, I may be back. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic