WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Serving static files from a cookieless domain (w/ MaxCDN) (7 posts)

  1. digitalsky
    Member
    Posted 1 year ago #

    When testing my site using the Pingdom tool it tells me that some of my static files could be served from a cookieless domain to increase performance.

    I'm using the latest version of W3 Total Cache in conjunction with MaxCDN. The CDN is working perfectly on my site (www.pr-tech.com) and I have added this code to my wp-config.php file...

    define('COOKIE_DOMAIN', 'www.pr-tech.com');

    That doesn't seem to take care of the issue though as it still says that static files on my CDN are still receiving cookies. Any idea how to fix this?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. m1mi.dan0s
    Member
    Posted 11 months ago #

    I'm having the same thing and I don't understand how to remove it.

    I also adjusted the mydomain.com to http://www.mydomain.com in the Google Analytics-code, cause that also seemed to set cookies.

    I have created a CNAME record pointing to the custom domain provided by MaxCDN.

    Still getting the error.

  3. digitalsky
    Member
    Posted 11 months ago #

    I fixed this and if I remember correctly I did it by going to my MaxCDN control panel and specifying a time period 7 days or more for cookies. I can't remember if that's exactly what I did but I know I fixed it... Ughh, I'll try and remember.

  4. coralseait
    Member
    Posted 10 months ago #

    Has there been any more info on this? I have the issue as well, and I'm trying to solve it as YSlow gives me an F on it.

  5. Angelica Costa
    Member
    Posted 9 months ago #

    Yeah, it worked for me. Go to maxcdn, settings of the zone and set "Override Cache-Control Header" to 7 days.
    ALSO: go to the cdn option in w3 total cache and in the advanced section, check "set cookie domain to (your domain)".

  6. Bluemad
    Member
    Posted 7 months ago #

    Yes, same issue, but MaxCDN already Override Cache-Control Header set for 7 days. Also W3Total setup www domain as the cookies domain on wp-config.php file. But still Pindom tools show me my cdn domains have cookies.

    Is it Google Analytics for WordPress plugin issue or any other issue?

  7. Ajith Edassery
    Member
    Posted 5 months ago #

    Hey, thanks for this MaxCDN setting :) Have been fighting the 'cookieless..' report for a whole. It just worked with the 7 days setting as angelcosta mentioned. The 'set cookie domain' was already on.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic