WordPress.org

Ready to get started?Download WordPress

Forums

Fantastic ElasticSearch
[resolved] Server URL (12 posts)

  1. SecureFreak
    Member
    Posted 1 year ago #

    What do you put in here if we have our own Elastic Search instance?

    http://wordpress.org/extend/plugins/fantastic-elasticsearch/

  2. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    I haven't tested using a hostname/port, but it would be simple to add. I will go through tonight and try with local instance and put up a change.

  3. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    That being said, are you able to still test with your own server? From what I understand, you can just put

    http://myserver:8080/

    the plugin will then append the index name to be

    http://myserver:8080/index/

    and the API will be consistent with what hosted services provide. ElasticSearch is accessed using a restful protocol, so it should be work the same even with your own instance.

  4. SecureFreak
    Member
    Posted 1 year ago #

    Still doesn't work.

    [Fri Jan 25 22:11:25.862630 2013] [:error] [pid 26549] [client 68.53.229.176:63332] PHP Warning:  Invalid argument supplied for foreach() in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/lib/nhp/options/options.php on line 257, referer: http://www.aircraftincidents.com/wp-admin/plugins.php
    [Fri Jan 25 22:11:34.331262 2013] [:error] [pid 27327] [client 68.53.229.176:63335] PHP Warning:  Invalid argument supplied for foreach() in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/lib/nhp/options/options.php on line 257, referer: http://www.aircraftincidents.com/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
    [Fri Jan 25 22:11:34.350329 2013] [:error] [pid 27327] [client 68.53.229.176:63335] PHP Warning:  Invalid argument supplied for foreach() in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/lib/nhp/options/options.php on line 690, referer: http://www.aircraftincidents.com/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
    [Fri Jan 25 22:11:34.352320 2013] [:error] [pid 27327] [client 68.53.229.176:63335] PHP Warning:  Invalid argument supplied for foreach() in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/lib/nhp/options/options.php on line 771, referer: http://www.aircraftincidents.com/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=
    [Fri Jan 25 22:12:34.254214 2013] [:error] [pid 26539] [client 68.53.229.176:63431] PHP Warning:  Invalid argument supplied for foreach() in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/lib/nhp/options/options.php on line 257, referer: http://www.aircraftincidents.com/wp-admin/admin.php?page=elastic_search
    [Fri Jan 25 22:12:34.270665 2013] [:error] [pid 26539] [client 68.53.229.176:63431] PHP Fatal error:  Class 'Elastica_Client' not found in /home/aircraft/www/wp-content/plugins/fantastic-elasticsearch/admin/sections/server-settings.php on line 12, referer: http://www.aircraftincidents.com/wp-admin/admin.php?page=elastic_search
  5. SecureFreak
    Member
    Posted 1 year ago #

    If I enable the search and leave everything else blank it works. If I try to fill out the server url it breaks.

  6. SecureFreak
    Member
    Posted 1 year ago #

    Server URL breaks it. It is the only one that breaks it when i put something in there. All other fields work. http://localhost:8080/ does not work.

  7. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I really don't know what else to do at this point. If you would like to debug it and submit a patch I will be glad to add. elasticsearch.php contains a spl_autoload_register call that you should be able to put some echo statements in and see if for some reason the path its attempting to lookup is invalid.

  8. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    i was able to reproduce this problem on one of my servers, will update soon as i get a fix in

  9. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    this is fixed in 1.1.1, the issue was lib/elastica needs to be lib/Elastica, on my machine the case didn't matter

  10. SecureFreak
    Member
    Posted 1 year ago #

    Can you please do some testing to see what is needed to get this working for a Elastic Search localhost setting? I have tried a few urls but all of them fail to connect.

  11. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    if you have downloaded elasticsearch and just ran it out the box, it will be by default "http://localhost:9200/".

    You need to also create the index first like so

    "curl -XPUT http://localhost:9200/myindexname/"

  12. SecureFreak
    Member
    Posted 1 year ago #

    Thanks, that got it up and running. Indexing over 150,000 posts now. Going to take a bit.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.