WordPress.org

Ready to get started?Download WordPress

Forums

Server understands but refuses 2fulfill request??? (4 posts)

  1. geekette
    Member
    Posted 9 years ago #

    Installation went fine and I'm able to log in and edit options. But when I click "view site", I get this error:

    error 403: Forbidden! The server understood the request, but is refusing to fulfill it. Authorization will not help and the request SHOULD NOT be repeated.

    My site url and database, etc values are correct.
    My host is 1and1.com and I'm using OS X (which probably shouldn't matter since the blog & error are web-based)
    Posts with similar issues mention ".htaccess" files but I see no such files in the wp1.5 archive that I downloaded.
    This is a new/first time install, so no upgrade issues and I havent created any posts at all.
    Any insight appreciated as I really don't want to have to try yet another blog pkg. My original idea was to install a couple pkgs & see which I preferred (hah!), but I've abandoned a Blosxom installation after spending an inordinate amount of time rectifying some host/server/formatting glitches and running into more...

    Thanks!

  2. vkaryl
    Member
    Posted 9 years ago #

    If there's an .htaccess file problem it will be on the server already. One isn't shipped with the wp distro. You should double check the setup on your host (I know others use 1and1, so it does work there) as to the .htaccess situation.

    You might also check the permissions on the folder in which you installed wp. Sometimes "forbidden" errors are directly a result of wrong permissions set....

  3. geekette
    Member
    Posted 9 years ago #

    I just discovered a .htacces file by using my FTP search function. It wasn't visible before because it was in a "logs" folder & I cannot change permissions or even open the folder! So even if it might just be the lofty htaccess file causing the errors, I can't verify yet.

    And I came across this while searching the 1&1 help: "Since we dont provide access to Apache error logs on shared hosting packages for technical reasons".

    So I guess it'll be another extensive round of emails with 1&1 techs to verify/change to correct permissions or location...

  4. geekette
    Member
    Posted 9 years ago #

    Okay! update:
    My current settings have my blog url [mydomain.com/My_Entries] different from my wordpress url [mydomain.com/wordpress]
    My blog page shows up when I enter my wordpress url, I get the nasty 403 msg when I enter my blog url.

    I tried putting in an index.php file in my preferred blog directory and tried again. This time I got an error indicating that it couldn't open due to not finding some file as requested on line4 of the php file. It obviously couldn't execute properly as it needs to be in the same folder as other wp files. But I don't want my wp & blog entries in the same directory!

    SO... I dug around & found a user response to the same problem in an older Wp version which said to alter index.php copy inside blog directory to say: "require('./wordpress/wp-blog-header.php');" but that worked ONLY if my blog url = mydomain.com with the wp dir as a subfolder. I also tried creating & placing htaccess file in suggested directories but it made no difference.

    So despite statements to the contrary, I must conclude that wp & blog folders cannot exist in different folders at least not with my given host settings... I hope documenting this may help other users with the same setup & problem...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.