WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Server time offset (6 posts)

  1. x3me88
    Member
    Posted 5 years ago #

    Hi,

    I have a time problem: The server time is set with a wrong time zone, so the time is some 16 hours behind "real" time. I can't even get it right by choosing the biggest UTC difference in the settings, but nevertheless I wouldn't want to modify the real time zone.

    Now, I'm also running a SMF forum on that server and SMF has a neat option called "Server time offset", which sets the time difference from the server time (if it is wrong, like in my case). But WordPress doesn't, and this creates me a lot of trouble because my feeds don't show up as fresh in feed readers.

    Is there any way I could set the time offset?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    The server time *should* be set to UTC. Period. All computers are supposed to be set to UTC. They then figure out their local time based on that and their timezone settings.

    So when you look at the Settings->General screen, you should see "UTC time is 2008-08-21 15:42:19" or whatever. Make sure that that value is correct. If not, then the server time needs to be fixed. Complain at your host until they do it. It is important that WordPress knows the real UTC time as well as the offset, because it uses both values in different places. Simply setting the offset larger won't fix the problem.

    You might consider trying my Automatic Timezone plugin.

  3. x3me88
    Member
    Posted 5 years ago #

    Yes, I know. And the UTC time is incorrect. And I have complained, a lot, but they still do not want to fix it. I will most likely change my host, but until then I would like to be able to somehow fix that time.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Sorry, but it simply can't be done. Like I said, WordPress needs to know *both* times, because in some places it uses the GMT/UTC time (feeds, for example). Increasing the offset to a ridiculously large number would make the display look right on the blog, but everything else would be wrong, including the internal times on the posts as well as the feeds not working properly in feed readers.

    The server time *must* be correct.

    However, if you manually edit the database and look in the wp_options table, you'll find a gmt_offset setting. The value of that is the offset. Manually set it really high and there you go. Won't fix your problems though.

  5. x3me88
    Member
    Posted 5 years ago #

    Ok, thanks, I'm just gonna have to speed up the host change then, this is really frustrating, and I've complained like a thousand times.

  6. cocteauboy
    Member
    Posted 5 years ago #

    I just found out my own servers are set to Mountain, while I am Eastern, making my timestamps show up as MST. It's very annoying.

    And really? Nothing I can do to offset that myself?

    troy (thanks!)

Topic Closed

This topic has been closed to new replies.

About this Topic