WordPress.org

Ready to get started?Download WordPress

Forums

Tweet Blender
[resolved] Server taking a performance hit from Tweet Blender (4 posts)

  1. traditum
    Member
    Posted 2 years ago #

    Hi everyone I love the plugin, works really well except for one thing: my host seems to dislike the performance hit that there server is taking from my use of it and decided to disable my access to that site temporarily. When I asked why I could not access my account they sent me the following email (some bits omitted):

    We have checked and found that your account causing high load on the server and affecting other running users. Your account php pages are causing extensive cpu usage on server. It is adversely affecting our servers. You can go through the following logs for your confirmation :
    =========================
    ******* 14882 0.1 0.6 114160 22196 ? S 06:38 0:00 | \_ /usr/bin/php /home/*******/public_html/*******/wp-content/plugins/tweet-blender/ws.php
    ******* 14923 0.1 0.6 114160 23572 ? S 06:38 0:00 | \_ /usr/bin/php /home/*******/public_html/*******/wp-content/plugins/tweet-blender/ws.php
    (repeated another 10 or so times)
    =========================

    Please explain why is it causing so much cpu usage and what steps will you take so that it doesn't happen in future ?

    Please feel free to contact us back in case of any further information.

    Thank you,
    *******,
    Technical Support Department
    *******

    Would it be that my the way I configured tweet blender is doing this (maybe it is refreshing too often)? Is there some 'usual suspect' for this type of thing? Have I just got a crappy host (very possible)? Or would it be something else?

    Obviously I would prefer to use this plugin than other ones but if my host keeps on getting shitty with me for some alleged performance hit and taking my site down I obviously have to disable it for the time being. I would appreciate any advise!

  2. traditum
    Member
    Posted 2 years ago #

    Bump!

    Come on guys any idea?

  3. kirilln
    Member
    Plugin Author

    Posted 2 years ago #

    Hey, this usually happens when you blend a lot of stuff together and you have a high traffic web site. The performance hit is from a script that stores and updates cache. Two main remedies for this:

    1) Make your widgets refresh less often so the cache is updated less often.
    2) If you have many usernames as sources, create a Twitter list, add them to that list, and then use just that list as the only source. This way instead of updating cache for each username the plugin will update the cache just once.

    If none of this helps you can just disable caching (it's a checkbox under WP Admin > Settings > Tweet Blender > Cache)

  4. traditum
    Member
    Posted 2 years ago #

    Thanks Kirilln!

    I suspected it was something like that. It was probably refreshing too often and there were a few users being used as sources.

    What is strange about this situation is that I don't think the site in question has very high traffic at all! :S

    It turns out that my host has disabled access to the TweetBlender plugin (grrrrr!) so I can't use it for now anyway. I plan to migrate all of my sites over to a VPS with a different host in the near future (so that this sort of thing stops happening)and I will implement your advise then!

    Cheers,

    Traditum

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic