WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Server refuse connection on wp-admin (12 posts)

  1. Watt
    Member
    Posted 4 years ago #

    I've just upgraded to v3.0 and can't access the admin area. The upgrade has made manually, upload/unzip. I have some security on my server that restricts 'bad' visitors from accessing my site for 10' every time I try to enter the admin area (wp-admin). For some reason, the server thinks I'm abusing resources, probably, or that I'm a bad bot. So, I'm banned for 10'.
    I cannot figure out why. The plugins are not the problem (I think); I've tried to rename the plugins folder to something else but didn't worked, either.I have buddypress installed (their latest version).
    Server runs on Centos 5, php5, mysql 5, apache 223. Wp is installed in the main, not in subfolder.
    Any ideas why this happens? The server logs are not saying much about this.

  2. I have some security on my server that restricts 'bad' visitors from accessing my site for 10' every time I try to enter the admin area.

    What are you using to do this?

  3. Watt
    Member
    Posted 4 years ago #

    That's another problem, can't remember exactly; the server was installed half year before. Can say for sure if suhosin, monit or fail2ban can do this :(
    But, after searching better, I've found a lot of error in the Apache's logs:

    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-config.php' (dev=2049 ino=0) was on gc-list for 15598293 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-content/plugins/auto-tag/auto-tag.php' (dev=2049 ino=0) was on gc-list for 15614270 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/default-embeds.php' (dev=2049 ino=0) was on gc-list for 15736882 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-content/plugins/akismet/akismet.php' (dev=2049 ino=0) was on gc-list for 15614286 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/vars.php' (dev=2049 ino=0) was on gc-list for 15737297 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/widgets.php' (dev=2049 ino=0) was on gc-list for 15737299 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/http.php' (dev=2049 ino=0) was on gc-list for 15736898 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/media.php' (dev=2049 ino=0) was on gc-list for 15737260 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/shortcodes.php' (dev=2049 ino=0) was on gc-list for 15737280 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/canonical.php' (dev=2049 ino=0) was on gc-list for 15736860 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/update.php' (dev=2049 ino=0) was on gc-list for 15737295 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/taxonomy.php' (dev=2049 ino=0) was on gc-list for 15737281 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/functions.wp-styles.php' (dev=2049 ino=0) was on gc-list for 15736896 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/class.wp-styles.php' (dev=2049 ino=0) was on gc-list for 15736876 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/functions.wp-scripts.php' (dev=2049 ino=0) was on gc-list for 15736895 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/class.wp-scripts.php' (dev=2049 ino=0) was on gc-list for 15736875 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/class.wp-dependencies.php' (dev=2049 ino=0) was on gc-list for 15736874 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/script-loader.php' (dev=2049 ino=0) was on gc-list for 15737279 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/deprecated.php' (dev=2049 ino=0) was on gc-list for 15736885 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/cron.php' (dev=2049 ino=0) was on gc-list for 15736881 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/kses.php' (dev=2049 ino=0) was on gc-list for 15737255 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/bookmark-template.php' (dev=2049 ino=0) was on gc-list for 15736857 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/bookmark.php' (dev=2049 ino=0) was on gc-list for 15736858 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/feed.php' (dev=2049 ino=0) was on gc-list for 15736892 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/rewrite.php' (dev=2049 ino=0) was on gc-list for 15737276 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/comment-template.php' (dev=2049 ino=0) was on gc-list for 15736878 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/comment.php' (dev=2049 ino=0) was on gc-list for 15736879 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/category-template.php' (dev=2049 ino=0) was on gc-list for 15736862 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/category.php' (dev=2049 ino=0) was on gc-list for 15736863 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/post-template.php' (dev=2049 ino=0) was on gc-list for 15737270 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/post.php' (dev=2049 ino=0) was on gc-list for 15738306 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/author-template.php' (dev=2049 ino=0) was on gc-list for 15736856 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/link-template.php' (dev=2049 ino=0) was on gc-list for 15737256 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/general-template.php' (dev=2049 ino=0) was on gc-list for 15736897 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/meta.php' (dev=2049 ino=0) was on gc-list for 15737261 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/user.php' (dev=2049 ino=0) was on gc-list for 15737296 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/theme.php' (dev=2049 ino=0) was on gc-list for 15737294 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/query.php' (dev=2049 ino=0) was on gc-list for 15737273 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/capabilities.php' (dev=2049 ino=0) was on gc-list for 15736861 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/formatting.php' (dev=2049 ino=0) was on gc-list for 15736893 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/l10n.php' (dev=2049 ino=0) was on gc-list for 15738292 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/pomo/streams.php' (dev=2049 ino=0) was on gc-list for 15737268 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/pomo/entry.php' (dev=2049 ino=0) was on gc-list for 15737264 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/pomo/translations.php' (dev=2049 ino=0) was on gc-list for 15737269 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/pomo/mo.php' (dev=2049 ino=0) was on gc-list for 15737266 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/default-filters.php' (dev=2049 ino=0) was on gc-list for 15736883 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/plugin.php' (dev=2049 ino=0) was on gc-list for 15737263 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/cache.php' (dev=2049 ino=0) was on gc-list for 15736859 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/wp-db.php' (dev=2049 ino=0) was on gc-list for 15737301 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/classes.php' (dev=2049 ino=0) was on gc-list for 15736877 seconds
    [Fri Jun 18 15:02:22 2010] [apc-warning] GC cache entry '/home/atat/public_html/wp-includes/functions.php' (dev=2049 ino=0) was on gc-lis

  4. This is definitely not a WordPress issue. It looks like a server-side issue. You'll have to contact your hosting provider for help.

  5. Watt
    Member
    Posted 4 years ago #

    Well, I'm on dedicated, cannot contact anyone :( I must find the solution myself.
    It looks like WordPress has an issue with APC, but can't find it.
    Any ideas?

  6. Watt
    Member
    Posted 4 years ago #

    Still nothing, I'm trying every day the same things:
    - disable plugins, upload the wordpress 3, replace the old w2.92, chmod the files and folder 755 (except some needed 777) and still nothing. The first page only loads the first 4-5 lines, until <title> - after title is blank.
    The admin page tries to open (can see the title of the page in the browser's bar) then it stops. And, I'm again banned for 10 minutes. I think the server is 'seeing' me like a bad bot or something, can't understand what, in the new w3, can cause this.

  7. Watt
    Member
    Posted 4 years ago #

    Bad news again, I'm afraid I'll never be able upgrade or install the 3rd wordpress. I've installed Wp3 on a sub-domain on the same server and it does the same thing. I can access everything without problems, except the admin area. When this happens, the server, again, locks me outside for a while. I cannot change the security settings on the server, I honestly don't know what is doing this, but I also don't think I want to change something. It must, though, be something on the Wp3 side I can modify to allow me the access and not ban me again.
    Any Wp3 dev. can advice me on this?
    Thanks!

  8. Watt
    Member
    Posted 4 years ago #

    Here, found the problem (I hope); is a Wp3 issue, after all:

    Jun 30 21:11:30 F031 suhosin[15304]: ALERT - script tried to increase memory_limit to 268435456 bytes which is above the allowed value (attacker '119.42.74.117', file '/home/dom/public_html/wp-admin/admin.php', line 96)

    So, Wp3 is trying to increase to 256M (why it needs so much!?!) and suhosin blocks me outside. I'll try to find a way to delete the line in the admin.php file.
    The line is:

    @ini_set( 'memory_limit', apply_filters( 'admin_memory_limit', '256M' ) );

    Does the above appear in other Wp3 files or only in admin.php?!

  9. Watt
    Member
    Posted 4 years ago #

    OK. Is working now; so, my last post here, in case other are having the same issue, removing the line:

    @ini_set( 'memory_limit', apply_filters( 'admin_memory_limit', '256M' ) );

    from the wp-admin/admin.php, will solve the issue :)
    Cheers!

  10. abbyfender
    Member
    Posted 4 years ago #

    Hi,
    I just read your posts and I am experiencing a similar issue, but I am not sure if it is the exact problem. I cannot access a single page with out safari dropping down a secure login box requiring me to enter my password and username (which is always rejected) every single time a new page is entered. It is so frustrating. I am running the 3.0 version and using linux. Godaddy is my hosting provider. I have tried everything I know to disable this security thing. However, if I click on cancel it allows me to enter the page, but my subscribers won't know that. Any advice?

  11. Watt
    Member
    Posted 3 years ago #

    Sorry for the late response, I don't enter here too much.
    No, I don't know what can I say to you. Maybe you have an image in a folder secured with a htaccess, I have no idea. This can make the site load, even if you click the cancel button, still the image will not load. I'd check the source code and try to open all the files there in the browser.
    Good luck!

  12. sguk
    Member
    Posted 3 years ago #

    Hi, for a way of solving this without editing wp-admin.php (which could become overwritten in updates)

    see this post

    Hope it helps.... I've got grey hairs and very tired today!!!

Topic Closed

This topic has been closed to new replies.

About this Topic