WordPress.org

Ready to get started?Download WordPress

Forums

server overload - hosting overload - plugin overloading server (18 posts)

  1. Ivan Jaquez
    Member
    Posted 3 years ago #

    I received an email from my hosting company stating that my wordpress mu installation is causing server overloading. I disabled all of the plugin that might be causing this issue but the problem continues. Looking in forums i found that some plugins like "yet another related post" plugin is causing this problem to some wordpress mu users, so I disabled it as well but nothing happens. The last email i got from the hosting reads like this:

    We regret to inform you that your application is still overloading our server. Please check exact log:

    c268309 5398 18.5 0.6 47740 28264 ? SN 13:04 0:00 /hsphere/shared/php5/bin/php-cgi -c /hsphere/local/home/c268309/mysite.com/cgi-bin/php.ini HTTP_USER_AGENT=Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html) SERVER_PORT=80 HTTP_HOST=society.mysite.com HTTP_FROM=googlebot(at)googlebot.com DOCUMENT_ROOT=/hsphere/local/home/c268309/mysite.com SCRIPT_FILENAME=/hsphere/local/home/c268309/mysite.com/cgi-bin/php5-custom-ini.cgi REQUEST_URI=/the-passion-of-the-baptist-not-the-christ/ SCRIPT_NAME=/cgi-bin/php5-custom-ini.cgi HTTP_CONNECTION=Keep-alive PHP_FCGI_CHILDREN=3 PATH_INFO=/index.php REMOTE_PORT=58200 PATH=/usr/local/bin:/usr/bin:/bin PWD=/hsphere/local/home/c268309/mysite.com/cgi-bin SERVER_ADMIN=webmaster@mysite.com REDIRECT_STATUS=200 PATH_TRANSLATED=/hsphere/local/home/c268309/mysite.com/index.php HTTP_ACCEPT=*/* REMOTE_ADDR=66.249.71.122 SHLVL=0 SERVER_NAME=mysite.com SERVER_SOFTWARE=Apache QUERY_STRING= SERVER_ADDR=98.131.70.87 GATEWAY_INTERFACE=CGI/1.1 SERVER_PROTOCOL=HTTP/1.1 HTTP_ACCEPT_ENCODING=gzip,deflate REDIRECT_URL=/index.php REQUEST_METHOD=GET
    c268309 5440 17.5 0.7 48416 29436 ? SN 13:04 0:00 /hsphere/shared/php5/bin/php-cgi -c /hsphere/local/home/c268309/mysite.com/cgi-bin/php.ini HTTP_USER_AGENT=WordPress/3.0; http://society.mysite.com SERVER_PORT=80 HTTP_HOST=society.mysite.com DOCUMENT_ROOT=/hsphere/local/home/c268309/mysite.com SCRIPT_FILENAME=/hsphere/local/home/c268309/mysite.com/cgi-bin/php5-custom-ini.cgi REQUEST_URI=/wp-cron.php?doing_wp_cron SCRIPT_NAME=/cgi-bin/php5-custom-ini.cgi PHP_FCGI_CHILDREN=3 PATH_INFO=/wp-cron.php REMOTE_PORT=35212 PATH=/usr/local/bin:/usr/bin:/bin PWD=/hsphere/local/home/c268309/mysite.com/cgi-bin SERVER_ADMIN=webmaster@mysite.com REDIRECT_STATUS=200 REDIRECT_QUERY_STRING=doing_wp_cron PATH_TRANSLATED=/hsphere/local/home/c268309/mysite.com/wp-cron.php HTTP_ACCEPT=*/* REMOTE_ADDR=98.131.70.87 SHLVL=0 SERVER_NAME=mysite.com CONTENT_LENGTH=0 SERVER_SOFTWARE=Apache QUERY_STRING=doing_wp_cron SERVER_ADDR=98.131.70.87 GATEWAY_INTERFACE=CGI/1.1 SERVER_PROTOCOL=HTTP/1.0 HTTP_ACCEPT_ENCODING=deflate;q=1.0, compress;q=0.5 REDIRECT_URL=/wp-cron.php CONTENT_TYPE=application/x-www-form-urlencoded REQUEST_METHOD=POST
    c268309 5444 41.0 0.6 47736 28232 ? SN 13:04 0:00 /hsphere/shared/php5/bin/php-cgi -c /hsphere/local/home/c268309/mysite.com/cgi-bin/php.ini HTTP_USER_AGENT=R6_FeedFetcher(www.radian6.com/crawler) SERVER_PORT=80 HTTP_HOST=haircare.mysite.com HTTP_ACCEPT_CHARSET=ISO-8859-1, ISO-8859-2, ISO-8859-5, ISO-8859-7, windows-1250, windows-1251, windows-1253, Big5, EUC-JP, EUC-KR, x-euc-tw, HZ-GB2312, ISO-2022-CN, ISO-2022-KR, ISO-2022-JP, UTF-8, Shift_JIS, UTF-16BE, UTF-16LE, KOI8-R, x-mac-cyrillic, IBM866, IBM855, TIS-620, cp866 DOCUMENT_ROOT=/hsphere/local/home/c268309/mysite.com SCRIPT_FILENAME=/hsphere/local/home/c268309/mysite.com/cgi-bin/php5-custom-ini.cgi REQUEST_URI=/ottawa-barbershop-to-serve-all-after-complaint/ SCRIPT_NAME=/cgi-bin/php5-custom-ini.cgi PHP_FCGI_CHILDREN=3 PATH_INFO=/index.php REMOTE_PORT=6612 PATH=/usr/local/bin:/usr/bin:/bin PWD=/hsphere/local/home/c268309/mysite.com/cgi-bin SERVER_ADMIN=webmaster@mysite.com REDIRECT_STATUS=200 PATH_TRANSLATED=/hsphere/local/home/c268309/mysite.com/index.php REMOTE_ADDR=142.166.170.101 SHLVL=0 SERVER_NAME=mysite.com SERVER_SOFTWARE=Apache QUERY_STRING= SERVER_ADDR=98.131.70.87 GATEWAY_INTERFACE=CGI/1.1 SERVER_PROTOCOL=HTTP/1.1 HTTP_ACCEPT_ENCODING=gzip, deflate REDIRECT_URL=/index.php CONTENT_TYPE=text/html; charset=ISO-8859-1 REQUEST_METHOD=GET
    c268309 6243 32.0 0.6 47408 27584 ? RN 13:05 0:00 /hsphere/shared/php5/bin/php-cgi -c /hsphere/local/home/c268309/mysite.com/cgi-bin/php.ini HTTP_X_MOZ=prefetch HTTP_KEEP_ALIVE=115 HTTP_USER_AGENT=Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729) SERVER_PORT=80 HTTP_HOST=blogger.mysite.com HTTP_ACCEPT_CHARSET=ISO-8859-1,utf-8;q=0.7,*;q=0.7 DOCUMENT_ROOT=/hsphere/local/home/c268309/mysite.com SCRIPT_FILENAME=/hsphere/local/home/c268309/mysite.com/cgi-bin/php5-custom-ini.cgi REQUEST_URI=/copenhagen-cronaca-di-un-accordo-fallito-intervista-a-federico-pistono/ SCRIPT_NAME=/cgi-bin/php5-custom-ini.cgi HTTP_CONNECTION=keep-alive PHP_FCGI_CHILDREN=3 PATH_INFO=/index.php REMOTE_PORT=61078 PATH=/usr/local/bin:/usr/bin:/bin PWD=/hsphere/local/home/c268309/mysite.com/cgi-bin SERVER_ADMIN=webmaster@mysite.com REDIRECT_STATUS=200 HTTP_ACCEPT_LANGUAGE=en-us,en;q=0.5 PATH_TRANSLATED=/hsphere/local/home/c268309/mysite.com/index.php HTTP_REFERER=http://blogger.mysite.com/p90x-anthony-le-results-part-1-p90x-review/ HTTP_ACCEPT=text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 REMOTE_ADDR=24.178.120.64 SHLVL=0 SERVER_NAME=mysite.com SERVER_SOFTWARE=Apache QUERY_STRING= SERVER_ADDR=98.131.70.87 GATEWAY_INTERFACE=CGI/1.1 SERVER_PROTOCOL=HTTP/1.1 HTTP_ACCEPT_ENCODING=gzip,deflate REDIRECT_URL=/index.php REQUEST_METHOD=GET HTTP_COOKIE=__utma=98034432.784024881.1279376337.1279376337.1279649902.2; __utmc=98034432; __utmz=98034432.1279649902.2.2.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=asian%20nerd%20does%20p90x; __utmb=98034432.1.10.1279649902
    Should you have any further questions, feel free to contact us at anytime, we are available 24/7.

    Sincerely yours,
    Technical Support Dpt.
    ***********************************************************************

    Any help on this? I don't know what is happening here. I don't know how to read this log to fix this issue. Thanks in advance.

  2. Samuel B
    moderator
    Posted 3 years ago #

    most of those errors go through the cgi-bin I assume wordpress isn't in that folder?
    also, do you have any apps using cgi?

  3. How big is your site and what kind of hosting package are you on?

  4. Ivan Jaquez
    Member
    Posted 3 years ago #

    Hello Samuel and Andrea.Everything was ok but suddenly my site started to overload the server.I installed wpmu n the root directory. I'm not sure if i have any apps using cgi. The plugins I was using are: wprobot,all in one seo pack,contextual related posts,wpunique,Best post summary, and instant wordpress link which needs eoncube to work.I disabled all of them to see if this fix the problem. I'm using an unlimited shared server package from ixwebhosting.com. My site is an autoblogging network that has 100 blogs n subdomain.Have you heard about a plugin called wp-supercache? Some guys recommend this plugin to help on the server overload issue.Thanks guys.

  5. Yes, use the caching plugin.

  6. Ivan Jaquez
    Member
    Posted 3 years ago #

    Ok. I will try the wp-supercache. I hope it helps. I'll keep you informed. Thanks Andrea and Samuel.

  7. If WP Super Cache doesn't help, there's also W3 Total Cache, though that requires a little more techno savvy AND only the dev version is 3.0 compatible.

    I'm using an unlimited shared server package from ixwebhosting.com

    FYI, shared server hosting may not be enough for MultiSite. I'd consider an upgrade to VPS.

  8. Usually just 100 blogs wouldn't do it, but if it's getting hit hard by traffic, then yeah. Time to think about a VPS. Do the caching first tho.

  9. Ivan Jaquez
    Member
    Posted 3 years ago #

    Thank you guys. Let's check and see what happen. See you tomorrow.

  10. It also depends on your host. Personally I don't trust 'unlimited' anything, and to me 'unlimited shared hosting' generally translates as 'We oversell our servers' which could easily cause an overload with very little additional traffic on your part :/

  11. 'unlimited shared hosting' never means resources. always read the fine print. ;)

  12. Tony Cecala
    Member
    Posted 3 years ago #

    If I understand auto-blogging, your site is generating posts across all the blogs w/o human effort and perhaps even scraping and using RSS feeds. This is going to require a much more powerful platform.

  13. Ivan Jaquez
    Member
    Posted 3 years ago #

    I'm using wprobot autoblogging plugin to feed the blogs. I deactivated all the plugins and after that the hosting company contacted me a few minutes ago and told me that the server overloading issue has been resolved.I think that the next logical step is to activate wp-supercache in every blog and then activate the rest of the plugins. I was using mainly wprobot,all in one seo pack,contextual related posts,wpunique,Best post summary, and instant wordpress link (which needs eoncube to work). I hope it helps. Any tip or advice?

  14. Ivan Jaquez
    Member
    Posted 3 years ago #

    Thanks in advance.

  15. Ivan Jaquez
    Member
    Posted 3 years ago #

    Thanks a lot ipstenu :-)

  16. stoffb
    Member
    Posted 2 years ago #

    Hi there,

    I'm using WP-supercache on my website hautstyle and I've recently upgraded my server to a VPS one but my server keeps craching when there is a burst of visitors. It happens when I share one of my post on stumbleupon but I'm not talking masses of traffic, probs around 500 in one go.

    Are there some plug-ins that are not recommend or use a lot of memory which I might be using?

    A little help would be great as I seem to spend more and more on server but the problem remains...

    Many thanks in advance

  17. stoffb - Make a new topic please :)

    List the plugins you're using. Also if you're on a VPS, consider installing server caching, turning on minification and getting into httpd.conf optomization.

Topic Closed

This topic has been closed to new replies.

About this Topic