WordPress.org

Ready to get started?Download WordPress

Forums

FeedWordPress
"Server not found" error even when feed exists (5 posts)

  1. Annough Lykin
    Member
    Posted 5 months ago #

    With around 5% of blogs I syndicate I get the error "Server not found". I checked the blogs and also their feed. Blogs are standard blogs from wordpress or blogger, with standard settings. Normally there is no problem when syndicating these. I cannot detect an error in the blog's feed, so my question is, if this is a known problem or occurs to someone else. Is there a solution for it?

    Thank you for help.

    http://wordpress.org/plugins/feedwordpress/

  2. WPChina
    Member
    Posted 5 months ago #

    Log into the server where you have WordPress and FWP installed by SSH. The ping the not found servers. For example:

    ping yahoo.com

    That would be the first step to make sure your server can communicate and find the DNS for those not found sites. I had this issue once before.

  3. Annough Lykin
    Member
    Posted 2 months ago #

    I have now 4 blogs where this error occurs constantly.

    2 of them are wordpress blogs hosted on wordpress.com and 2 are blogspot blogs hosted on blogspot.*

    http://chalicecarling.blogspot.de/feeds/posts/default
    http://beatriceserendipity.blogspot.co.uk/feeds/posts/default
    http://untouchablelife.wordpress.com/feed/
    http://josiedecuir.wordpress.com/feed/

    As I don't have problems with other blogs hosted on wordpress or blogspot this really puzzles me.

  4. Annough Lykin
    Member
    Posted 2 months ago #

    I tried the ping and ping works from the server on all 4 blogs

  5. Annough Lykin
    Member
    Posted 2 months ago #

    Ok, finally I found the solution. I'm posting it, if someone else has the same problem.

    I had the chance to get admin rights for one of the blogs and checked the settings and played around.

    It seems to be a timeout problem. It occurs for blogs with large feeds. E.g. both wordpress blogs had set the maximal amount of posts for the feed to 50. Reduced to 30 I could syndicate the blogs without problems.

    On blogspot there seems to be now way to reduce length of the feed in the settings. Here another trick helps:

    Instead of trying to enter the following address in the syndicate field
    http://myblogname.blogspot.com/
    or
    http://myblogname.blogspot.com/feeds/posts/

    reduce the feed manually:
    http://myblogname.blogspot.com/feeds/posts/default?max-results=10

    and all works.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags