WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Server log file errors referring to 'magicfiles' (7 posts)

  1. John O
    Member
    Posted 3 years ago #

    Hi,

    A client of mine running a wordpress powered website is getting a large number of errors in their server log files referring to 'magicfiles' - I have searched these forums and the errors are identical to those being reported in the following threads:

    http://wordpress.org/search/magicfiles?forums=1

    However none of these threads have a definitive explanation or solution as to the probable/possible cause of these errors.

    Below is a copy of one of the log file errors (domain and IP removed)

    [Mon Oct 18 17:09:46 2010] [error] [client xx.xx.xx.xx]
    file -C -m magicfiles, referer: http://www.clientdomain.com/
    [Mon Oct 18 17:09:46 2010] [error] [client xx.xx.xx.xx] Try `file --help' for more information., referer: http://www.clientdomain.com/
    [Mon Oct 18 17:09:46 2010] [error] [client xx.xx.xx.xx] Usage: file [-bcikLhnNsvz] [-f namefile] [-F separator] [-m magicfiles] file..., referer: http://www.clientdomain.com/

    Any help at all would be most appreciated. The referring page always seems to be the home page, and googling the error leads me to either the WordPress support threads, or talk about magic_quotes, php bugs and timthumbs but I am out of my depth there. The version of PHP being used is 5.2.11

    Thanks in advance.

  2. Mark / t31os
    Moderator
    Posted 3 years ago #

    No idea what the issue is, but see if anything listed here is familiar to your problem.
    http://www.google.co.uk/search?q=-f+namefile+-F+separator+-m+magicfiles

    Maybe something on one of the results will hold some clues..

  3. DigitalSquid
    Member
    Posted 3 years ago #

    What theme is the client using?

  4. John O
    Member
    Posted 3 years ago #

    It's called Arthemia.

  5. DigitalSquid
    Member
    Posted 3 years ago #

    This thread: http://code.google.com/p/timthumb/issues/detail?id=15

    Seems to show a way of stopping the error messages (editing line 234 of /wp-content/themes/arthemia/scripts/timthumb.php) but I don't think it actually foxes the issue.

    Have you tried talking to your web host. Maybe it's an issue with the server you site is hosted on.

  6. John O
    Member
    Posted 3 years ago #

    Thanks for that - I'll give that a go and see what happens and post back when I check the logs. I will speak to the webhost too, though this is the first time I have had problems with timthumb.php on one of their servers.

  7. John O
    Member
    Posted 3 years ago #

    Hi,

    Just wanted to say I tried the solution and hey presto no more errors! thanks ao much for the help. These forums are always so helpful and informative.

Topic Closed

This topic has been closed to new replies.

About this Topic