WordPress.org

Ready to get started?Download WordPress

Forums

Server Error when trying to access dashboards (9 posts)

  1. Rick
    Member
    Posted 1 year ago #

    Hi all,

    I know that many threads have been opened about this issue...there is even a fresh one few lines below. But I didn't want to add my problem to somebody else's and create confusion.

    Before I start:

    • I've carefully read the pages suggested in "welcome to the multisite forum" post.
    • I've carefully followed the instructions found there and in some other blogs.
    • I use wordpress 3.5
    • I have a subfolders network: (www.mysite.it/it; http://www.mysite.it/en)

    I created two sites in subfolders, one for each language that will be on my website: /it/ and /en/. You can visit the two websites even if there is no theme, just text.

    When I try to access to the dashboards I get the 500 internal server error. I used to get a "too many redirects", but this got fixed following the suggestion in this thread: http://wordpress.org/support/topic/multisite-this-webpage-has-a-redirect-loop

    These are the lines I've added to my wp-config.php:

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.eguardoilmondodaunoblo.it');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('WP_DEFAULT_THEME', 'theSource');

    The website url is http://www.eguardoilmondodaunoblo.it

    Any idea of what the problem might be? Can it be related to my hosting provider?

    thanks a lot!

  2. http://www.eguardoilmondodaunoblo.it/en/ is unstyled.

    What's in your .htaccess?

  3. Rick
    Member
    Posted 1 year ago #

    Hi Ipstenu thanks for your answer.
    Yes, both /en/ and /it/ are unstyled.

    this is the .htaccess:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) home/mhd-01/www.eguardoilmondodaunoblo.it/htdocs/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ home/mhd-01/www.eguardoilmondodaunoblo.it/htdocs/$2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress
  4. Okay, the likely issue is that your server's httpd.conf file doesn't have 'all' set in AllowOverride.

    If you can't edit that, ask your host.

  5. Rick
    Member
    Posted 1 year ago #

    Thank you very much!
    I'll get in touch with my host and will come back to either close the topic or post more questions :)

    have a nice day!

  6. Rick
    Member
    Posted 1 year ago #

    Hi, I'm back.
    My hosting provider informed me that the AllowOverride is set to "all", but still I get that looping error when i try to access to the dashboard:
    http://www.eguardoilmondodaunoblo.it/en/wp-admin

    Is there something wrong in my .htaccess or wp-config?

    thanks a lot for your patience.

  7. andymacleod
    Member
    Posted 1 year ago #

    I don't know if this will help - but I had the same issue (including similar contact with my host) and I got it working by changing my .htaccess file:

    http://wordpress.org/support/topic/problems-setting-up-a-network-from-a-fresh-install?replies=3

  8. Your issue was different, Andy, you didn't replace the .htaccess initially, you appended to it :)

    figurehead, can you ask your host exactly what AllowOverride is set to? It may need to be 'Options All'

    Also http://eguardoilmondodaunoblo.it/en/wp-admin doesn't work at all which is odd. Your server should support both that and the www version.

  9. Rick
    Member
    Posted 1 year ago #

    Yeah I know this www issue is the host's fault. This is all a test and I'm gonna change provider as soon as i go officially live with the website.

    However, if you say that this problem of mine might be due to the host i might as well change it right now. My other option is tu purchase a plugin but i'd rather go for the multisite as it does exactly what i need.

    I'll try again contacting them even though i'm not too hopeful...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.