WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Server Error on Subdomain Dashboard (8 posts)

  1. rachel4595
    Member
    Posted 11 months ago #

    I've just moved my site from a temp domain to it's permanent http://www.kidsallaround.com and have the main site working and was able to finally add a new site (thanks to help from this board). However, when I tried to access the dashboard for the new site casper.kidsallaround.com I received a server error. Checked the server logs and found this:

    Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    my .htaccess file is as follows:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    My httpd-config file:

    /** Enable or disable Worpress Multi-site features **/
    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'www.kidsallaround.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    I have verified with bluehost that my wildcard subdomain is set up(public_html/wildcard) correctly and they said mod_rewrite will work if I have it in my .htaccess file.

    My network admin dashboard and my dashboard for the main site work. I tried adding an additional subdomain and still get the error. I tried changing to subfolders (followed steps here) and still get the error. I tried adding AllowOveride it that crashes the whole site.
    Bluehost says its a wordpress problem but everything I had read on here leads me to believe it's the server. Any help would be greatly appreciated.

  2. rachel4595
    Member
    Posted 11 months ago #

    I am also getting a 404 error when I go to http://www.kidsallaround.com/wp-login

  3. casper.kidsallaround.com directs to a loading page that is NOT WordPress.

    I don't think you set up subdomains right.

    And it's http://www.kidsallaround.com/wp-login.php :) Works fine.

  4. rachel4595
    Member
    Posted 11 months ago #

    I had previously had casper.kidsallaround.com set up as a subdomain on bluehost, rather than just using multisite. I deleted it when I decided to set up multisite. Could this be the problem? Do I need to make additional changes beside deleting on bluehost?

  5. rachel4595
    Member
    Posted 11 months ago #

    okay, now I am getting this error:
    File does not exist: /home2/kidsalla/public_html/wildcard/wp-admin

    Do I need to add something to the htaccess file in the wildcard folder? Or an admin file?

  6. /home2/kidsalla/public_html/wildcard/wp-admin

    No, that means wildcard subdomains is setup wrong.

    https://my.bluehost.com/cgi/help/527 did you do that?

  7. rachel4595
    Member
    Posted 11 months ago #

    Okay, finally got someone at bluehost willing to help me. I left the /wildcard in the name when setting up my subdomain. Should have deleted that and just left it public_html/
    Fixed that and it worked. That's something I didn't see in any tutorial re: setting up wildcard subdomain - maybe it's bluehost specific but for someone muddling through this that was important!

  8. rachel4595
    Member
    Posted 11 months ago #

    Thanks!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.