WordPress.org

Ready to get started?Download WordPress

Forums

Server Configuration an Unexpected Error Occurred (6 posts)

  1. RobTheBrand
    Member
    Posted 1 year ago #

    Hi, I have just had a VM cloud server provisioned and had Plesk 11 installed on it.

    The auto-install scripts for wordpress work - it creates the sites easily. But none of the wordpress sites allow me import or add plugins. I don't want to have to use ftp to install these all the time. I get the following error:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    Can you please assist. I have scoured the forums for this and have been unable to locate a suitable solution.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try checking your site's error logs for a more specific error message. Your host should be able to help you in accessing your site's error logs.

  3. RobTheBrand
    Member
    Posted 1 year ago #

    I took a look and it says this:

    [Wed Apr 10 14:28:30 2013] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?

    and then the following ones!

    [Thu Apr 11 23:29:16 2013] [error] [client 208.115.113.90] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 00:04:03 2013] [error] [client 157.55.32.114] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 00:08:40 2013] [error] [client 157.55.32.114] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/tag
    [Fri Apr 12 00:41:07 2013] [error] [client 208.115.113.90] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/solutions
    [Fri Apr 12 00:42:28 2013] [error] [client 123.125.71.91] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 01:26:24 2013] [error] [client 208.115.111.74] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 02:31:27 2013] [error] [client 208.115.111.74] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/author
    [Fri Apr 12 02:31:30 2013] [error] [client 208.115.111.74] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/server-security
    [Fri Apr 12 02:31:32 2013] [error] [client 208.115.111.74] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/shortcode-columns
    [Fri Apr 12 02:35:02 2013] [error] [client 213.186.127.7] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/feed
    [Fri Apr 12 03:39:32 2013] [error] [client 66.249.74.79] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 03:39:33 2013] [error] [client 66.249.74.79] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/tag
    [Fri Apr 12 03:44:34 2013] [error] [client 78.158.11.226] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/wp-content/themes/cloudhost-parent/framework/static/css/prettyphoto.css
    [Fri Apr 12 04:03:08 2013] [error] [client 66.193.171.245] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/user
    [Fri Apr 12 04:06:33 2013] [error] [client 66.249.74.79] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/vygczoyumljuy.html
    [Fri Apr 12 05:19:49 2013] [error] [client 157.55.33.80] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 05:21:35 2013] [error] [client 157.55.33.80] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/tag
    [Fri Apr 12 06:10:43 2013] [error] [client 66.249.74.117] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 06:30:29 2013] [error] [client 65.55.213.246] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/robots.txt
    [Fri Apr 12 06:30:29 2013] [error] [client 65.55.213.246] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/sitemap_index.xml

    Does the first error mean anything important. Some of the files in the other errors seem to be there and some are missing..

    Can you shed any light on this. Its a dedicated server so my hosts aren't much help.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    The first error can be safely ignored at this stage. The only error that really sticks out is:

    [Fri Apr 12 03:44:34 2013] [error] [client 78.158.11.226] File does not exist: /var/www/vhosts/ninemedia.co.nz/httpdocs/wp-content/themes/cloudhost-parent/framework/static/css/prettyphoto.css

    which suggest that you're missing a CSS file in your theme. It would probably be worth re-uploading a complete fresh copy of the theme to wp-content/themes using FTP.

  5. RobTheBrand
    Member
    Posted 1 year ago #

    yes, thank you for that, but the file is there I check it and made it writable so its a strange one. I originally installed that theme via FTP.

    And it still doesn't explain why Im unable to install plugins from the API. I get the below error.

    http://ninemedia.co.nz/wp-content/uploads/2013/04/screenshot.png

  6. RobTheBrand
    Member
    Posted 1 year ago #

    I found the problem.. It is related to Fast CGI operating and not comunicating that well with the wordpress API.

    I temporarily switched it to Apache Module and it worked but it is not an ideal solution as the permissions are all scrambled. See article below:

    http://wpguru.co.uk/2012/02/the-problem-with-running-php-as-fastcgi-application/

    Looks like I will need to do some work on the server. Typically this would work on other servers running Plesk 11 but this new server I have provisioned is a cloud server and will require a developer to code something to configure it so it works with FastCGI.

    The problem may be unique to my server set up. Thank you for your help on this topic. If I find out what they do to get it working I will post it on here. But it may not be useful to anyone else.

Topic Closed

This topic has been closed to new replies.

About this Topic