WordPress.org

Ready to get started?Download WordPress

Forums

Server 500 error when updating to 3.1 (8 posts)

  1. James Laws
    The WP Ninjas
    Posted 3 years ago #

    I am on iis7 and I uploaded the new file for 3.1 and I'm getting a server error 500 when I try to login to the admin. Site works fine on the front end. I just can't access admin.

    Any suggestions?

  2. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Tried going back to 3.0.5 and now I'm still getting the same issue. All worked fine before the upgrade attempt.

  3. Try renaming your .htaccess to old.htaccess and see if you can get in. If so, let WordPress regenerate your .htaccess file by saving permalinks.

  4. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Unfortunately this is a Windows server with iis7 so no htaccess to edit. There is a web.config and I did remove to see if that could be the issue but it didn't solve the problem.

  5. Urg. Okay. Try reasaving your permalinks. The only directions I know are for .htaccess alas :( http://dre.im/if-pages-return-a-404-after-wordpress-3-1-upgrade

  6. James Laws
    The WP Ninjas
    Posted 3 years ago #

    Thanks for the info but I tried the whole permalink reset thing. I can't do much with it because I can't login to my admin. Thats whats throwing the error. My front end works fine.

  7. leivajd
    Member
    Posted 3 years ago #

    Resaving permalinks worked for me, thanks

  8. Try a manual upgrade? Re-copy the files up. Maybe the wp-admin server got chunked.

    Also try turning off your plugins. You can rename the folder plugins-old and see if it lets you in.

Topic Closed

This topic has been closed to new replies.

About this Topic