WordPress.org

Ready to get started?Download WordPress

Forums

Server 2008, IIS 7, URL Rewrite, and 404s... (5 posts)

  1. Clifton Griffin
    Member
    Posted 5 years ago #

    I recently migrated my wordpress blogs from Server 2003 to Server 2008. This was for the purpose of using pretty permalinks with URL Rewrite under IIS 7.

    So far so good, everything is mostly working.

    The only problem I'm still having pertains to wordpress 404s. When I try to go to a blog post that doesn't' exist, I get a 500 internal server error. This happens whether or not I have /index.php/ trailing my URL or not, so I don't think it is related to my URL rewriting.

    I had this problem on 2003 as well, only then I got an IIS 404. I handled this by using a custom 404 that was actually designed to get around mod_rewrite, but also solved this problem.

    So, I ask: has anyone else seen this? It seems too consistent to be a fluke....any theories about what is happening?

    Applicable sites:
    http://clifgriffin.com
    http://prolutum.com

    Thanks in advance,
    Clifton

  2. Clifton Griffin
    Member
    Posted 5 years ago #

    I installed the Permalink Validator plugin. This has *most* fixed it, but I still get a completely blank page with some URLs.

    *sigh*

  3. Clifton Griffin
    Member
    Posted 5 years ago #

    Has anyone else seen this?

  4. Clifton Griffin
    Member
    Posted 5 years ago #

    I'm still looking for a solution to this.

    Does anyone have any idea why a plugin like permalink validator, or a custom 404 redirect is able to get around this?

    What am I missing?

  5. Doodlebee
    Member
    Posted 5 years ago #

    try adding "www" to your urls in settings:

    http://www.clifgriffin.com
    http://www.prolutum.com

Topic Closed

This topic has been closed to new replies.

About this Topic