WordPress.org

Ready to get started?Download WordPress

Forums

SEO Yoast plugin duplicate Page Title (12 posts)

  1. echofestival
    Member
    Posted 2 years ago #

    Hi all,

    So it seems that many have come accross this problem, and forgive my coding ignorance but I have no idea how to fix this.

    Using Bonsai theme template: http://themeforest.net/item/bonsai-minimalist-wordpress-theme/discussion/238277

    Blog: http://www.echofestival.com

    SO I am getting the duplicate page title, and in the title section of the Yoast SEO plugin I have selected force rewrite titles. But the problem still persists.

    I have read that I need to replace the title section of my header.php file with <title><?php wp_title(''); ?></title> but I have tried this already..??

    This is my header.php:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    What must I change?????

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    You first need to get rid of this,
    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display the static page information like the_title() here -->
    that is loading before <DOCTYPE>

    I only see one title, ECHO FESTIVAL, Makarska, Croatia 22nd - 24th JUNE 2012, if that is the title, in FF and in IE9.

  3. echofestival
    Member
    Posted 2 years ago #

    Sorry but where is:

    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display blog post information like the_title() here -->
    <!-- standard tags to display the static page information like the_title() here -->

    That you have referred to?

    If you look at my website page, for example this page: http://echofestival.com/about

    The title still appears after the page title ..... ???

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    The above code shows up in the source code before <DOCTYPE> which has to be first. That means IE will open in the quirks mode. More than likely they came from something you tried to install 4 times.

    On the travel page, which has the problem, this is on line 33 of the source code and is also on all the incorrect pages.

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.1.5 - http://yoast.com/wordpress/seo/ -->
    <link rel="canonical" href="http://echofestival.com/travel" />
    <!-- / Yoast WordPress SEO plugin. -->

    On the Travel page which has the correct title the above is absent as it is on all the correct pages.

    So the plugin is not working on all pages. Try deactivate the plugin and then delete it. Then reinstall it.

  5. echofestival
    Member
    Posted 2 years ago #

    Kmessinger I have deleted and re-installed the plug-in.

    The site title still appears after every page title....?

    So are you saying that I just need to removed those 4 lines that you have mentioned?

    I'm sorry but I did not completley understand you last comment?

  6. echofestival
    Member
    Posted 2 years ago #

    Currently the title section in my header.php looks like this: http://pastebin.com/LFXyqaJJ

    Did not understand the last help info, could someone help me?

  7. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    if the problem is within the meta title code of your theme, please contact the theme seller for support, as this seems to be a commercial theme with which this forum is unable to help.

  8. Gary Darling
    Member
    Posted 2 years ago #

    I had the same problem with Yoast, here's how I fixed it:

    • Change the default title tag to the simple one per Yoast's instructions (like you did above)
    • In the Title section of the SEO plugin, make your page and post titles look something like this: %%sitedesc%% | %%title%% | %%sitename%%
    • Update/save, flush your browser cache, and check your titles
    • You can change the tags around to your liking per Yoast's instructions
  9. echofestival
    Member
    Posted 2 years ago #

    Thanks gary darling, your advice has now pointed me in the right direction.

    So in my page title, I have added %%title%%, so that only that page title appears which is great.

    The last remaining issue, is the tab description of the website. (not sure if that's what you call it, but the little decription which you can see on the internet browser tab with your page open? If you get me...I think its the metadescription.

    Basically, is there a way to include a "-" in the Page title template box in SEO Yoast, so that I could put it next to %%title%% to then separate it from the website name?

    At the moment it looks like this: http://echofestival.com/our-family

    metadescription: Our FamilyEcho Festival

  10. echofestival
    Member
    Posted 2 years ago #

    Or to somehow revert back to the standard style of the page being Our Family | Echo Festival

  11. echofestival
    Member
    Posted 2 years ago #

    Ok so I am almost there.

    I changed the title tag to Yoast's description: <title><?php wp_title(''); ?></title> and I un-checked for re-write.

    So now, in page title section of Yoast SEO I have put in: %%title%% | %%sitename%%

    Which is fine for the Home & News page, as on the tab description of the page they read Home | Echo Festival and News | Echo Festival

    The problem is that on the remaining pages, on the page title they still appear About | Echo Festival, and so on..

    I just want to remove the | Echo Festival bit out of the page titles!!!!

  12. Gary Darling
    Member
    Posted 2 years ago #

    Well, you could put some php in there to test which page you are on, then change the title accordingly. I think that defeats the goal of the Yoast SEO plugin, though. If I remember correctly, Yoast claims that good SEO means that your page titles should always reflect your site name, as well as the keyword(s) of the page. That's probably why there is no easy way to disable that.

    That said, if you are really intent on it, I might use this psuedocode:

    'if ( is_home() || is_front_page() {
    code for my home page title
    } else if {
    is_page('News')
    code for my news page title
    } else {
    wp_title(' ');
    } end if );'

    I'm not a big fan of that because I think Yoast is on the right track. If someone is searching google and sees a link to your page, your site name is not obvious to them like it should be.

    But there it is.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags