WordPress.org

Ready to get started?Download WordPress

Forums

[SEO Smart Links] problem with using h2 tag (3 posts)

  1. Jonathan Dingman
    Member
    Posted 4 years ago #

    I found a problem with SEO Smart links

    when I do this:

    <h2 id="seo-smartlinks">SEO Smart Links</h2>

    it converts it to this:

    <h2 id=\"seo-smartlinks\">SEO Smart Links</h2>

    when I use the single quote, like this:

    <h2 id='seo-smartlinks'>SEO Smart Links</h2>

    it works just fine and returns this:

    <h2 id='seo-smartlinks'>SEO Smart Links</h2>

    figured this out by enabling and disabling the plugin. the problem disappears when I disable the plugin.

    any suggestions on a fix for it?

    http://wordpress.org/extend/plugins/seo-automatic-links/

  2. Vladimir Prelovac
    Member
    Posted 4 years ago #

    Finally found a way to do this with a regex. Will be a feature of next version.

  3. archon810
    Member
    Posted 3 years ago #

    I just spent about half an hour figuring out what is causing the issue and arrived at the same conclusion. It's the "Prevent linking in heading tags (h1,h2,h3,h4,h5,h6)." option that is doing it with double quotes.

    Could you please push the fix to trunk?

Topic Closed

This topic has been closed to new replies.

About this Topic