WordPress.org

Ready to get started?Download WordPress

Forums

SEO Rank Reporter
SEO Rank Reporter Stopped Working on Mar-29-2012 (8 posts)

  1. Terence
    Member
    Posted 2 years ago #

    All I see now is the records prior to Mar 29 and this error being reported...

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    What is the fix, David?

    http://wordpress.org/extend/plugins/seo-rank-reporter/

  2. Terence
    Member
    Posted 2 years ago #

    After twp updates its still broken and not reporting...

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

    cURL error number:22
    cURL error:The requested URL returned error: 503
    url:

  3. David Scoville
    Member
    Plugin Author

    Posted 2 years ago #

    Terence, are you on a shared host? Also, how many keywords are you tracking? This is probably due to the fact that Google is blocking your IP from reaching google.com. This is usually caused by others on your same IP who have spammed or overly pinged google.com.

    I may add the ability to add another IP to the reporter. But for now, the plugin probably won't check rankings until you get your own IP or switch hosts. Sorry about that. I don't think there's anything I can do.

    There are other options to check rankings. AuthorityLabs will do 10 keywords for free. SEOMoz will let you track 5 rankings per day.

  4. Terence
    Member
    Posted 2 years ago #

    Thanks David, for getting back to me.

    None of this explains why it ran for a week or two and then stopped.

    Its my own virtual server and its not shared. I have had two other sites on it in the past but they are now defunct.

    I am/was tracking about 15 keywords.

    There is only one site on my IP address (31.222.163.188) and it is my own IP address, so that's not what the problem is.

    I could easily switch hosts in an hour or so, but I don't think that's what needs to happen here, David.

    The site is behind the Cloud Flare firewall. Can you give me enough technical details that I can check with them that they are not blocking access for some reason.

    Other than that, any ideas?

  5. David Scoville
    Member
    Plugin Author

    Posted 2 years ago #

    The plugin uses php's Curl to get the search result. You'll need to check if there is an issue with that and your Firewall.

    The error appears when you try to add a keyword or click the "Check Rankings Now" button?

  6. Terence
    Member
    Posted 2 years ago #

    Yes, I concur with that, it does happen when it appears and I click the "Check Rankings Now" button.

    I am checking with the server admins at Cloudflare to see if there's an issue with CURL. There may be a related issues because I see in the Incoming Links dashboard widget this report now... RSS Error: A feed could not be found at http://blogsearch.google.com/blogsearch_feeds?scoring=d&ie=utf-8&num=10&output=rss&partner=wordpress&q=link:http://www.socialstrategy.co.uk/

    Like I say, I don't know if its connected, but I am investigating.

  7. Terence
    Member
    Posted 2 years ago #

    David, do you have an hard details on the RSS/Curle issue and why it should be a problem in particular for SEO Rank Reporter? If I can I would like to feed some more information to the server admins to see if they can figure it out.

    Last rank check was on Apr-17-2012
    Next rank check scheduled for Apr-20-2012
    "social strategy" - http://www.socialstrategy.co.uk/
    Rank: 6
    Mar-29-2012

  8. Terence
    Member
    Posted 1 year ago #

    Hey David. When are you going to do what most other developers would do and fix this problem by replacing cURL with the WordPress HTTP API. My installation hasn't worked since March and then it just stopped. The only help I got so far was the same advice ~ use AuthorityLabs to get 10 keywords free ~ but there is no "10 keywords free", just a free 30 day trial; not the same thing at all! And anyway, that doesn't fix the problem. How much longer are you going to ignore all these people complaining and give them the same bullshit answer. I'm not on a shared host. My IP is not blocked. But even if I was, your answer is not the solution. Most people ARE on shared hosting ~ you need to fix your software.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic