WordPress.org

Ready to get started?Download WordPress

Forums

Sending referrers (21 posts)

  1. anaxios
    Member
    Posted 10 years ago #

    I just installed WordPress today and I keep getting the following error message whenever I try ti change or add to my blog:
    "Sorry, you need to enable sending referrers, for this feature to work."
    I've read the forum threads and how it's talking about disabling firewalls or browser options. What can I do? Is it a problem with the server? Is there something on my hosting server I need to enable? I am throughly confused.

  2. Anonymous
    Unregistered
    Posted 10 years ago #

  3. OperaManiac
    Member
    Posted 10 years ago #

    u have any firewall installed?

  4. anaxios
    Member
    Posted 10 years ago #

    Thank you for the links, but they don't seem to help.
    As for a firewall, do you mean on my local machine? Would the WinXP firewall do that?

  5. anaxios
    Member
    Posted 10 years ago #

    I double checked and I don't have the WinXP firewall on

  6. anaxios
    Member
    Posted 10 years ago #

    So I am able to edit entries, but not delete them or do anything with my links

  7. OperaManiac
    Member
    Posted 10 years ago #

    this is weird. u cant possibly have disabled sending referrers to ur browsers without u knowing that urself so the only possibility that some anti virus or firewall is doin that for u... :(
    u have any antivirus installed that comes with privacy features or something?

  8. guboogi
    Member
    Posted 10 years ago #

    I have the same problem. Ever since I upgraded to 1.2 (from 1.0.2) I get this problem when trying to enable any plugins or even when trying to delete a comment. I am not running any firewalls (I disabled the Windows XP firewall as well) and all I have installed in Norton Antivirus 2003, and I don't see any option to enable referrers. I am using IE6 with default security settings. Can anyone suggest why I am having this problem? I'm considering just going back to 1.0.2 until this problem is fixed. Thanks in advance.

  9. CeeJayCee
    Member
    Posted 10 years ago #

    I added my own site to the trusted sites part and it seems to work (in Norton Firewall 2003)

  10. guboogi
    Member
    Posted 10 years ago #

    I don't even use Norton Firewall 2003 (unless it automatically comes with Norton Antivirus 2003 and I don't know how to get to it). I am not running any antivirus software that I know about, so I really have no idea what this referrer business is. Is there any other way around it?

  11. suzan
    Member
    Posted 10 years ago #

    I've got a conclusion for all Firefox Users!! (Mozilla should work as well, i think)
    You have to edit your config-file:
    Enter "about:config" in the adress-line.
    Search the line "network.http.sendRefererHeader"
    Set the value to "1"
    That's it!

  12. Nick Momrik
    Member
    Posted 10 years ago #

    I've never had a problem in Firefox...

  13. suzan
    Member
    Posted 10 years ago #

    I had, because the value was set to "0" in my settings. With this setting i always get the error "Sorry, you need to enable sending referrers, for this feature to work".
    Now i changed it, and everything works very fine.
    Maybe my conclusion may help some Firefox users, who have this problem as well and search in the forum for help.
    I am sorry, i can't help the IE users, because my IE send the referer automatically and i don't know what to change in IE, because i don't user this browser.

  14. kiawin
    Member
    Posted 10 years ago #

    but somehow... with my firefox 0.8... when i look in the about:config.. my "network.http.sendRefererHeader" is already set as 2. and even when i set to 1... the same error still come out when i try to add user as admin in the admin area.

  15. lute
    Member
    Posted 10 years ago #

    Same here, the line was set to 2 and still gave the error when I set it to 1.

  16. Anonymous
    Unregistered
    Posted 10 years ago #

    Well, I figured out my problem and it actually didn't have anything to do with referrers. This probably just pertains to me, but I'll post it just in case. It seems I had a somewhat unorthodox setup where I was using a different address than where I installed WordPress as my blog site (I had to manually change some of the functions for everything to work properly.) So when I upgraded my cookies kept me logged in but apparently I wasn't logged in "properly" as some things didn't work (since the paths were off.) Upon fixing my settings in the options I relogged in correctly and now it dcesn't give me the referrer error. Hope this helps someone. Good luck all.

  17. kiawin
    Member
    Posted 10 years ago #

    oh dear... anyone could give me a hand on this issue? it's been a week plus and still failed to obtain any solution :(

  18. Kerim
    Member
    Posted 10 years ago #

    I'm having the same problem. In firefox or in Omniweb, doesn't matter how things are set as far as the above mentioned setting is concerned. 1.2 alpha had been working fine...

  19. uiucgrad
    Member
    Posted 10 years ago #

    If you are using Norton Personal Firewall 2003-2004 here is the answer as found on the Norton website.
    Some Web pages require referrer information before allowing you to view their page. If you want to allow referrer information to pass to a particular Web page, you must create a rule for it.
    To create a rule
    Open Norton Internet Security or Norton Personal Firewall.
    Do one of the following.
    In Norton Internet Security/Norton Personal Firewall 2003, click Options > Internet Security or Personal Firewall (This step is not always needed), and then click the Web Content tab.
    In Norton Internet Security/Norton Personal Firewall 2004, double-click Privacy Control, and then click Advanced.
    Click Add Site. A new site/domain box appears.
    Enter the name of the site that you want to receive the referrer information and click OK. In this example, it will be http://www.symantec.com. The site name appears in the left frame of the Options window.
    Click the name of the new site.
    Click the Global Settings tab.
    In the "Information about visited sites" section, clear "Use default settings."
    Click Permit.
    Click OK to close the Options window.
    Norton Support Reference

  20. blondeofmind
    Member
    Posted 9 years ago #

    thanks uiucgrad thats worked

  21. spiff06
    Member
    Posted 9 years ago #

    Thanks, that was it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.