WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Sender email address not showing (4 posts)

  1. stickFinger
    Member
    Posted 1 year ago #

    Hi i´ve been using Contact Form since the beggining but with the 3.5.2 and WP 3.6 i´m having problems with any html tags, including the sender email address.

    Here is my very simple message body( and yes i´ve checked the "use html")
    ============================
    From: [your-name] <[your-email]>
    Subject: [your-subject]

    Message body:
    [your-message]

    --
    Email enviado via formulário em my site: http://mysite.org
    =======================================================
    using the < > makes [your-email] disapears completely from message body and removing then the sender appears again but it´s not clickable anymore. The same happens to my site address. It seems to be something stripping off any html inside my message body.

    Any clue on this?
    Thanks.

    PS. I´m using buddypress (the latest) and also tried to switch to default bd press and wp themes but no luck

    Ps2. funny but if i use < strong > From: </ strong > i get the correct style applied to message body

    http://wordpress.org/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Use &lt; and &gt; instead of < and > when you use them in HTML and they are not used as parts of HTML tags.

  3. stickFinger
    Member
    Posted 1 year ago #

    Thank you Takayuki for your response.
    So you mean that i have to set my message body like this:

    ==================================
    From: [your-name] <[your-email]>

    etc
    etc.
    ======================================

    Thank you

  4. crabarr
    Member
    Posted 4 months ago #

    Thanks Tayayuki!
    This works especially well for Contact Form 7. If you select use html content type in your mail settings for your contact form, WordPress can eliminate the < and the >, so sender emails don't show up. But if you use something like:
    [sender-name] &lt;[sender-email]&gt; instead of the default [sender-name] <[sender-email]> the sender email address works properly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic