WordPress.org

Ready to get started?Download WordPress

Forums

semiologic having probs with photopress (11 posts)

  1. Ovidiu
    Member
    Posted 8 years ago #

    hi guys,

    I recently stumbled upon semiologic spftware and am trying to set up a blog which will/should also include a photogallery.

    I am trying to use photopress, but I am open for other suggestions as long as the photos reside on my server so no flickr or similar services.

    the problem is the following:

    when viewing an album with the semiologic 3 column theme I get this error:
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/web20/web/wordpress/wp-content/plugins/photopress/pp_album.php:5) in /var/www/web20/web/wordpress/wp-content/themes/semiologic-3-col/install.php on line 10

    any ideas how to fix that?

    and besides that how would I make a category or page that appears in the navbar of the semiologic 3 column theme called pictures, and when clicked gives an ordered list of subcategories or displays the appropiate thumbs for the existent albums from photopress?

  2. Denis de Bernardy
    Member
    Posted 8 years ago #

    edit pp_album.php and remove the extra spaces at the beginning and end of the file.

    Re: the navbar issue, look into Admin > options > nav menu

  3. Ovidiu
    Member
    Posted 8 years ago #

    thx for the reply, although it doesn't work. my pp_album.php looks like this:

    <?php
    /* Photopress album template. Designed to work with the WordPress default theme. If it doesn't work with your theme, try modifying it to look like your theme's index.php (replace the Loop with <?php pp_album(); ?> See pp_album_css.php for the CSS, which can also be customized. The pp_wrap id can be used to customize the headings and whatnot, with something like: #pp_wrap h2 { font-family: Arial; } */
    ?>

    <?php get_header(); ?>

    <div id="content" class="narrowcolumn">

    <div id="pp_wrap">
    <h2>' . __('Photos','photopress'); ?></h2>
    <?php pp_album(); ?>
    </div>

    </div>

    <?php get_footer(); ?>

    there are no spaces ....

    concerning the navbar: I know how to get a certain category or page to display in the nav menu, I just don't know how to get a category or page to display the content of pp_album.php...

    and another problem which seems related: I have deactivated the calendar tile but from time to time (30 mins or so) it keeps getting activated!? very strange...

    btw. I saw on your sit eyou can be hired... is there a minimum wage/pay ? I mean what I need to be done is peanuts I gues, I am just not competent enough and do not have enough time. If I write you an email with details about what I need done, would you consider making me an offer about how much that would cost me? if you are interested at all... that is

  4. Denis de Bernardy
    Member
    Posted 8 years ago #

    email denis at semiologic dot com

  5. Denis de Bernardy
    Member
    Posted 8 years ago #

    It looks as if the theme is trying to autoinstall itself, hence the headers already sent error. make sure that the semiologic CMS plugin is activated.

    also, edit your config.php and add the line:

    define('DISABLE_CACHE', true);

    this will disable the WP object cache, which will likely fix your 'tile gets reactivated' issue.

    feel free to send the other issues at the above mentionned address.

  6. Ovidiu
    Member
    Posted 8 years ago #

    I guess you meant the wp-config.php file.
    I added that line and will check results tomorrow...

    you'll soon get an email with a summary of my needs in terms of wordpress/blogging and a link to the page as it is atm

  7. Ovidiu
    Member
    Posted 8 years ago #

    changing the wp-config file did not help. The calendar is bac k :-)

    you'll get an email from ovidiu @ ...

  8. Ovidiu
    Member
    Posted 8 years ago #

    @ denis
    did you get my mail? its coming from ovidiu at pacura dot ru

  9. Denis de Bernardy
    Member
    Posted 8 years ago #

    yes, I even answered it -- i'll send the answer again.

  10. Ovidiu
    Member
    Posted 8 years ago #

    hmmm, no incoming mails, no errors...
    try pacuraru at web dot de please

  11. Denis de Bernardy
    Member
    Posted 8 years ago #

    ... my computer broke yesterday -- I no longer have your questions nor your answers at hand :/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags