WordPress.org

Ready to get started?Download WordPress

Forums

Self-hosted blog admin login redirects to wordpress.org (43 posts)

  1. megs1383
    Member
    Posted 2 years ago #

    I've been having issues with my self-hosted WordPress blog since I upgraded to the latest version of WordPress.

    I had this self-hosted blog (www.meganbastian.com/wordpress) running smoothly for a while, until in January when I upgraded wordpress to v3.3.1, I suddenly lost my theme and my blog no longer shows up in my blogger dashboard. I can no longer access the backend through http://www.meganbastian.com/wordpress/wp-login.php, because when I enter my username and password, it redirects to http://www.meganbastian.wordpress.com.

    I also have another blog on wordpress.com (www.meganbastian.wordpress.com) which I use for testing purposes. Is having both of these domains a cause of my issue? I've read a few other similar posts and haven't found a solution. Any advice is appreciated.

  2. wpismypuppet
    Member
    Posted 2 years ago #

    Hi megs1383,

    It looks as though half of your styles and scripts point to http://wordpress.com/meganmakes/wp-content/themes/folioway and the other half point to http://meganbastian.com/wordpress/wp-content/themes/folioway/. Pretty weird!

    I'm not sure what the upgrade could have done to the database to make some changes, but one thing you could try is FTPing into your site, downloading and saving any .htaccess file you come across, then deleting (from the server itself) those same .htaccess files.

    I'm guessing one of those has some bad data in it causing the redirects to happen. Let me know if that works.

  3. Kevin Muldoon
    Member
    Posted 2 years ago #

    I recommend checking your htaccess file. You have perhaps overwritten the file.

    http://www.meganbastian.wordpress.com is on a separate domain so shouldn't be related to this problem.

  4. megs1383
    Member
    Posted 2 years ago #

    Thanks for the feedback. I logged into my FTP and backed up my files, but didn't find any .htaccess files in my WordPress directory (or in any of the subfolders I checked). Do I need to replace this file? If so, how do I go about doing that?

  5. wpismypuppet
    Member
    Posted 2 years ago #

    .htaccess files are hidden by default. Most FTP applications will show hidden files, but some are set to not show them by default. Look in your FTP application setting for a hide/show hidden files option. Make sure that's checked to show hidden files.

    If it is, and there are still no .htaccess files (usually in the root WordPress folder and sometimes in the wp-admin folder), then the only other thing I can think of is that your WordPress database table containing options is set to point to the wrong URL.

    FileZilla is a good FTP program that shows hidden files by default and is really easy to use... http://filezilla-project.org/

    Hope this helps.

  6. Kevin Muldoon
    Member
    Posted 2 years ago #

    If the .htaccess file isn't there, simply upload a blank .htaccess file and make it writeable. Then change the permalinks in the admin area and WordPress will update the file for you :)

  7. megs1383
    Member
    Posted 2 years ago #

    Still a no-go using finding the .htaccess file using Fetch and Filezilla. For some reason I feel like it at one time did have .htaccess file, but I don't know what could have happened to it. Since I have everything backed up, I might try to upload an older saved version to see if that makes a difference.

    How can I check my database table?

  8. megs1383
    Member
    Posted 2 years ago #

    I replaced the files with my older backup files with no change.

    I also tried adding a .htaccess file (to the WordPress directory) and it gave me an error message when I went to meganbastian.com/wordpress:

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache Server at meganbastian.com Port 80"

    The same error happened when I tried to add .htaccess into the wp-admin directory.

    I do have other blogs that I don't use (one of them being meganmakes.wordpress.com and the other being meganbastian.wordpress.com. Would getting rid of these stop the redirect that is happening?

    I am so confused!

  9. birdie breeze
    Member
    Posted 2 years ago #

    I have the same problem and also it reverted to a WP theme I wasn't using. My GPP theme is missing and I cant get in the backend to switch it.

    http://wordpress.org/support/topic/redirect-loop-on-wp-loginphp?replies=1

    It also happened to my other WP site but just the login.php issue.

    I think it is a .htaccess issue

  10. Kevin Muldoon
    Member
    Posted 2 years ago #

    If you can send me temporary ftp access and an admin login I can fix this in a few minutes.

  11. birdie breeze
    Member
    Posted 2 years ago #

    I had the same error when I changed my .htaccess file

    but there must be something missing to it or ?

  12. birdie breeze
    Member
    Posted 2 years ago #

    There may be a place you can enable "see hidden files"
    I'm with Hostgator and I do make sure that is checked

  13. Please note - We do not recommend giving ANY total internet stranger your passwords. Kevin, man, please don't encourage people to do that. Not everyone is trustworthy, and making people think it's okay to give out a password isn't helpful.

  14. birdie breeze
    Member
    Posted 2 years ago #

    it would be great if someone would contact hosts that provide a lot of WP sites and give them the fix and also post it on a sticky....seems to be pretty common....also I have a few sites on different hosts, and just need to know how to fix it myself. Thanks

  15. megs1383
    Member
    Posted 2 years ago #

    Thanks Kevin, but ditto birdie, I'd rather try to understand the problem so that I'm able to fix it myself.

    I do have the "see hidden files" setting checked, and there appears to be nothing there as far as .htaccess files. I'm going to try to learn more about the MYSQL database to see if anything is weird with that. I am a total newb with this backend stuff, but am looking forward to learning more as I go...

  16. Kevin Muldoon
    Member
    Posted 2 years ago #

    @Ipstenu - I am not trying to encourage anything and I understand where you are coming from. However sometimes it is difficult for beginners to understand how things work etc.

    I run WP Mods and help people out with wordpress problems every week. I do agree that people shouldn't post passwords publicly etc and not everyone should be trusted.

  17. esmi
    Forum Moderator
    Posted 2 years ago #

    It's not your personal reputation that was questioned. It's the whole concept of encouraging people to pass sensitive server access info onto a stranger on a forum that is the issue. Would you give your house keys to someone you only met in the street 5 minutes ago?

  18. Kevin Muldoon
    Member
    Posted 2 years ago #

    @Esmi - Firstly, I wasn't encouraging them to post any details publicly. I thought that would be pretty clear :)

    Again, I do understand that this should't be encouraged etc. However, I think it can be silly to spend 3 hours trying to explain how htaccess etc works when someone who is familiar with wordpress can sort this problem in under two minutes.

  19. birdie breeze
    Member
    Posted 2 years ago #

    This is becoming more and more of an issue for peeps who upgraded.

    There needs to be instructions posted on a sticky....and given to ISP hosts.

    - birdie

  20. esmi
    Forum Moderator
    Posted 2 years ago #

    wasn't encouraging them to post any details publicly.

    I agree. And if I implied that, I apologise unreservedly.

    someone who is familiar with wordpress can sort this problem in under two minutes

    But that rests in a huge assumption - that this person can be trusted. Unfortunately not every poster to this forum can be. :-(

  21. Kevin Muldoon
    Member
    Posted 2 years ago #

    @esmi - I totally agree. I don't like giving out my login details either unless it's a plugin or theme developer I have been working with. :)

  22. Kevin Muldoon
    Member
    Posted 2 years ago #

    @megs1383 - if there is no htaccess file there, the quickest thing to resolve this would be to create a blank file and save it as .htaccess. Alternatively, create this in your file manager via your host. The file should be placed in the root of your WordPress installation.

    Then go to http://meganbastian.com/wordpress/wp-admin/options-permalink.php and set the permalinks (you may have to change the permissions of the file to 755 or 777 temporarily to do this).

    On a site note, have you not thought about using the name blog instead of wordpress i.e. http://meganbastian.com/blog/

  23. esmi
    Forum Moderator
    Posted 2 years ago #

    @birdie breeze: Actually, if you look at the larger picture, it's not a common issue at all. There are only 2 people with the problem, in this topic and I've not seen it anywhere else. So that strongly suggests that it's server and/or site specific. Which isn't quite the same as saying that it applies to the hosts in general. In your particular case, I think your hosts' support may have done more damage than good and that it might be better if any further discussion continued within your own topic. Your situation is quite different to the original poster's

    @megs1383: Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  24. Kevin Muldoon
    Member
    Posted 2 years ago #

    On a site issue, I wouldn't advise anyone tampering with the contents of the .htaccess file unless you know exactly how it works. It controls how urls are generated (amongst other things) so you shouldn't change anything unless you know how to change things back should things go wrong.

  25. birdie breeze
    Member
    Posted 2 years ago #

    Oh, I have been rooting around, and another person posted a new thread a few hours ago....they just have different subject headings. Different Topic/Thread - same exact issue. Everyone is chasing their own tails.

    On my site, everything has been done, except not sure if they re-upped the wp-admin and wp-includes folders - BUT, they did tell me they checked them all and they were sound. I'll try the re-upload of them. I did the plug-in's trick, and Twenty Eleven was switched in. Which, I want out and my GPP as soon as this is fixed. Clearly the techs had gotten the same info you supplied.

  26. esmi
    Forum Moderator
    Posted 2 years ago #

    @birdie breeze: Please continue in your own topic - not this one. Your situation is quite different to the original poster's.

  27. birdie breeze
    Member
    Posted 2 years ago #

    Yes, I agree it was likely one of the techs, that was working on it to help solve the memory 1010 error that was happening post 3.3.1 upgrade, in the media library...but so, it is a problem that started with and around 3.3.1 issues and others working on it.

    I did start my own topic the other day - no replies

  28. birdie breeze
    Member
    Posted 2 years ago #

    Thanks Kevin, your advice seems to apply to my case.

  29. megs1383
    Member
    Posted 2 years ago #

    @esmi I tried replaced w-admin and wp-includes from a freshlyy downloaded wordpress file, with no change. I also replaced the themes and plugins folder from the fresh wordpress folder (I haev a backup of course). Is replacing the folder different than resetting the folder? Or could there still be an internal setting somewhere that is trying to call up my old theme/plugins?

    @kevin, yes I had been thinking about changing the name to /blog, or maybe even it's own complete url. But right now, this blog is more of a personal recipe & project keeper than something that I am looking to generate a ton of followers to. So I've been more focused on trying to work out the kinks and get a look I love before taking it any further than that.

    I placed the .htaccess file in the /wordpress directory and now receive an "Internal File Error" message, and am not able to see anything on the permalink page but an "Internal File Error" message as well.

  30. Kevin Muldoon
    Member
    Posted 2 years ago #

    What does your .htaccess file say. Is it empty or has it been modified?

Topic Closed

This topic has been closed to new replies.

About this Topic