WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Select Menu
"Selectively Activate Theme Locations" not working (4 posts)

  1. imkane
    Member
    Posted 1 year ago #

    I have two WP 3 menus but only want to display one for mobile devices.

    When I set "Activate All Theme Locations" to OFF and then turn ON one of the menus, on my Android there's NO responsive menus (just the normal menus) and both are shown.

    So my only option is to set "Activate All Theme Locations" to ON, but I'm stuck with both responsive menus now on mobile devices.

    Here's the site:
    http://dev.shoeporn.com

    Any ideas?

  2. sevenspark
    Member
    Plugin Author

    Posted 1 year ago #

    What does your wp_nav_menu call look like? Is it using the theme_location parameter appropriately?

  3. imkane
    Member
    Posted 1 year ago #

    Ahhhh..that definitely helped. I was missing that parameter. Thanks :)

    Now on my Android the "Categories" menu is shown in the responsive style, and the "Pages" menu is shown in regular style.

    Shouldn't the "Pages" menu be completely hidden on mobile devices, based on these settings?
    http://d.pr/i/weQS

    If not, how do I hide the "Pages" menu?

  4. sevenspark
    Member
    Plugin Author

    Posted 1 year ago #

    Based on those settings, Responsive Select Menu will not act upon your Pages menu at all - it only affects those that are activated :)

    If you want to turn the Pages menu into a responsive select menu, activate it. If not, just add some CSS in a media query to hide it at small sizes (RSM replaces existing menus with select menus, it doesn't just hide menus as that's generally not the expected UI behavior)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic