WordPress.org

Ready to get started?Download WordPress

Forums

"selective" Japanese text display (7 posts)

  1. franzsy
    Member
    Posted 6 years ago #

    Hello guys! I have just created http://www.srwg-w.org

    I had Bluehost as my host and had 2.2 installed, and then I saw 2.3 was available so I followed instructions, FTPed it and upgraded it.

    I used to run a bilingual JP-EN blog and I'm running my own site now so I'm gonna do the same thing again. The question is, my Japanese text show up as ???? or question marks, but my Japanese CATEGORIES show up pretty fine. Check out my link above. How do I get to display my Japanese text on both the title and text areas?

    Just for notice, I installed the "Character set conversion" plugin, and that's just about it. Can someone help me on this please? I'm new and kind of confused (tried reading the other similar posts to no avail, or I couldn't understand it much).

    Thanx!

  2. adamrice
    Member
    Posted 6 years ago #

    You don't need that plugin. WP uses UTF-8 as its encoding method by default, and that supports Japanese. I suspect that plugin is processing your blog-entry text, but doesn't know what to do with Japanese, resulting in "????". It's probably not processing your category names, which is why they're coming through OK.

  3. moshu
    Member
    Posted 6 years ago #

    On a clean WP 2.3 install I just copied that category name into the title and post content area and it shows up perfectly.
    So, it might be the plugin as adamrice said above or something else interfering with the normal encoding.

  4. nelson-ray
    Member
    Posted 6 years ago #

    franzsy -

    most likely you created a new wp-config.php file during your upgrade to wordpress 2.3. you actually need to keep the old wp-config.php you had for wordpress 2.2. If you don't have wpconfig.php from your wordpress 2.2 install ... go into your current wp-config.php and comment out or remove these lines :

    define('DB_CHARSET', 'utf8');

    define('DB_COLLATE', '');

    that should solve your japanese text problems.

  5. maiki
    Member
    Posted 6 years ago #

    I am having the same issue. I use 2.3 from SVN, and my config file contains those lines. I have used Japanese in posts before, without any plugins for that functionality, just UTF-8, so I am going to poke around and see if I have posted anything since upgrading.

    Any other pointers?

  6. moshu
    Member
    Posted 6 years ago #

    What other pointers do you need once it was told: DELETE those two lines. Period.

  7. craigxmartin
    Member
    Posted 6 years ago #

    I am having the very same problem, and I have checked my wp-config file (new installation of WP 2.5), and it does not have those two lines. I have seen other posts recommending deleting these two lines, but if they are not there, and one is having the exact same problem with Japanese turning to question marks, and one's settings are set to UTF-8, how can the problem be resolved? I am entering the Japanese both directly into the post window, and pasting it in from another program like MS Word or notebook, all with the same results.
    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic