WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Selectable recipients not working (4 posts)

  1. eric_the_grey
    Member
    Posted 1 year ago #

    This was working before, but I've noticed it's not working now. I'm not certain how long it's been down.

    I've got a form with several recipients set as a selectable (with pipes) option, but the email fails to be sent (red box)

    This is my setup:

    <p>Your Email (required)<br />
        [email* your-email] </p>
    <p>Send email to: (required) <br />
    [select your-recipient: ""
        "Chapter Board | board@example.org"
        "President | president@example.org"
        "Treasury Chair | treasury@example.org"
        "Quartermaster | qm@example.org"
        "Webmaster | webmaster@example.org"]</p>
    <p>Subject<br />
        [text your-subject] </p>
    <p>Your Message<br />
        [textarea your-message] </p>
    <p>[submit "Send"]</p>

    My To: field has this:
    [your-recipient]

    Unfortunately, according to my email long plugin when I select an address and send it, the form tries to send to "[your- recipient]" instead of the email address I've selected.

    I've found one post that has a solution, indicated that they added a blank line at the beginning. I've done this, but it hasn't worked.

    All other forms, going to a specific set individual, are working with no issues, so it's not my mail setup.

    Any ideas what I could be doing wrong, or what the solution to this may be?

    Eric the Grey

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Sue
    Member
    Posted 1 year ago #

    Take out the colon and blank line after [select your-recipient: "" ?

    I have this working and I don't have a colon and I don't have a blank line. If they are required to select a recipient, there shouldn't be a blank entry...right?

    [select your-recipient: ""
    "Chapter Board | board@example.org"
    "President | president@example.org"
    "Treasury Chair | treasury@example.org"
    "Quartermaster | qm@example.org"
    "Webmaster | webmaster@example.org"]</p>

  3. buzztone
    Member
    Posted 1 year ago #

    Colon is the main problem. Can include blank line as follows:

    <p>Send email to: (required) <br />
    [select your-recipient include_blank
        "Chapter Board | board@example.org"
        "President | president@example.org"
        "Treasury Chair | treasury@example.org"
        "Quartermaster | qm@example.org"
        "Webmaster | webmaster@example.org"]</p>
  4. eric_the_grey
    Member
    Posted 1 year ago #

    That was it. I'm not certain where it came from, but it works now.

    Thanks again both of you.

    Oh, and Sue, the "" was intended to include a blank line in the beginning. This forces the user to actually select an option, rather than sending the form to the first entry.
    The user of include_blank works the same way, probably better. I've changed my form to use that as well.

    Eric the Grey

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.