WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Selectable Recipient with Pipes no longer working (11 posts)

  1. MacDoodle
    Member
    Posted 1 year ago #

    I was using this method to allow users to select recipient:

    [select your-recipient "CEO|ceo@example.com" "Sales|sales@example.com" "Support|support@example.com"]

    It's no longer working and I'm wondering if anybody else is having the same issue. Nothing has changed on this site since the last time this working except updates to WP & CF7.

    Looking at the source code, what I'm seeing for the option values is
    <option value="CEO">CEO</option>

    Currently using WP 3.5.2, and CF7 3.4.2. I tried rolling back to CF7 3.4.1, but it didn't fix it.

    Any assistance appreciated!

    http://wordpress.org/extend/plugins/contact-form-7/

  2. MacDoodle
    Member
    Posted 1 year ago #

    This WAS NOT related to upgrades - it was an incomplete tag inside of the form.

  3. treb76
    Member
    Posted 1 year ago #

    I am experiencing the same problem. The Contact Form was working fine until i updated to 7.3.4.2. I have rolled back to 7.3.3.3 and it is working fine again. Every time I update to 7.3.4.2 I get a validation error when submitting the form. Any suggestions would be greatly appreciated.

  4. MacDoodle
    Member
    Posted 1 year ago #

    Check your "From" field - it should be

    [your-name] <[your-email]>

    If it's just [your-email] then the upgrade might be resetting it to that.

    In my case I thought another person with access to the admin had changed it, but now I'm not so sure it wasn't the upgrade.

  5. MacDoodle
    Member
    Posted 1 year ago #

    treb - let me clarify something...

    "your-name" & "your-email" refer to the name of the form fields where the sender's name an email are collected and the tags I quoted above should be setup accordingly.

  6. treb76
    Member
    Posted 1 year ago #

    Here is the syntax I am using:

    see http://www.ncfcc.us/rfc

    It works fine in 7.3.3.3 but when I update to 7.3.4.2 I get the validation error when attempting to submit the form.

    If while running 7.3.4.2 I remove [your-recipient] from the to field and leave webmaster@ncfcc.us it works and will only send the emails to webmaster@ncfcc.us, which defeats the purpose of having emails distributed to the appropriate individuals.

    <p>Your name: (required)
    [text* sender-name /85] </p>
    
    <p> I would like to get the documents in the following manner (required):
     [checkbox* checkbox-570 use_label_element exclusive "Email"  "Pickup"]</p>
    
    <p>Your email address: (required)
    [email* sender-email /65 akismet:author_email]</p>
    
    <p>Your phone number and extension: (required)
    [text* yourphonenumber /16] </p> 
    
    <p>Your fax number:
    [text  yourfaxnumber /12]  
    
    <p> You must select a Case Type: (required) [select* your-recipient "Click for a list of available Case Types |"
    "Civil Records - CVM, CVD, CVS, SP, M | Joe@nccourts.org"
    "Criminal Records - Traffic Citations, CR | Kay@nccourts.org"
    "Estates - E |Thet@nccourts.org"
    
    <p>Case number:
    2 digit year plus type CVD, CVM, CVS, SP plus case number, example 12CVD12345
    [text casenumber /15]</p>
    
    <p>Plaintiff's name: (required) Last Name first then First Name
    [text*  plaintiff /75] </p> 
    
    <p>Defendant's name: Last Name first then First Name
    [text defendant /75] </p>
    
     <p>Please provide specific information in order not to delay your request.</p>
    [textarea your-message] </p>
    
    <p><span style="font-size:14px;">Please enter the following (below): [captchac captcha-101 size:l] &nbsp<p> [captchar captcha-101]
    
    <p>[submit "Send"]</p>
    
    To: [your-recipient],webmaster@ncfcc.us

    Thanks SO VERY MUCH FOR YOUR HELP!

  7. MacDoodle
    Member
    Posted 1 year ago #

    Have you tried removing the webmaster address from the "to" field and add it to a cc or bcc in the "additional headers" section?

  8. treb76
    Member
    Posted 1 year ago #

    7.3.3.3 was working fine. I just updated to 7.3.4.2 to try your recommendations. I stated by removing webmaster@ncfcc.us from the "To" filed and and leaving "[your-recipient]" and I get "Failed to send your message. Please try later or contact the administrator by another method." If I remove "[your-recipient]" and insert "webmaster@ncfcc.us" in the "To" field it goes through fine.

    Not sure of proper syntax for adding cc or bcc to additional fields.

  9. treb76
    Member
    Posted 1 year ago #

    Seems like 7.3.4.2 looks at [your-recipient] differently than in 7.3.3.3?

  10. treb76
    Member
    Posted 1 year ago #

    Is there a simple way to go from 7.3.4.2 back to 7.3.3.3 without having to delete 7.3.4.2, reinstall 7.3.3.3 and having to recreate the above contact form?

  11. MacDoodle
    Member
    Posted 1 year ago #

    Enter [your-recipient] in the Mail "To:" section and in the "Additional headers" area, enter "bcc: webmaster@ncfcc.us" -- remove that address from the "To" area.

    Make sure you have removed the comma after [your-recipient].

    Double check that your mail "From" info looks exactly like this[sender-name] <[sender-email]>

    If none of that works, then I would try removing selection without an email address (Click for a list of available Case Types) and/or the commas from your "your-recipients" list.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.